Failed to read file on Daydream deploy

Anytime I try to launch on Google Daydream, it says Failed to read file. Null Stream Line: 1 Ch: 0

If I relaunch the app it works, but this is annoying.

Hello nesrak1,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick question:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed list of steps to reproduce this this issue on our end?
  3. Could your provide screen shots of any blueprints/settings that may be involved (this would include any project settings that have been changed)?
  4. What device are you experiencing this issue on?
  5. What is the exact version of the current OS that is being run on the device?
  1. With a clean VR project, yes it does. I haven’t tested on a regular mobile app yet without Google VR.
  2. From GVR4UR [1) Go to Edit->Project Settings 2) Engine->Input: Click “Default Touch Interface” and click “Clear” 3) Platforms->Android: Click both “Configure Now” buttons in the red boxes. Set the package name, SDK versions to 24, and enable fullscreen immersive. Check “arm64” and uncheck “armv7”. Set “Configure GoogleVR Deployment Mode” to “Daydream”. 4) Platforms->Android SDK: Select the folder for each item, and the SDK API levels to “android-24” 5) Close out of that window and go to Edit->Plugins. 6) Built-In: Virtual Reality: Disable everything but Google VR. 7) Input Devices: Check Google VR Motion Controller.]
  3. Not many screenshots you need other than the one above.
  4. Google Pixel
  5. Android 7.1.1

After running several tests I have been unable to reproduce this issue on our end with the information provided. I have follow your steps and I do not receive the error mentioned in this post. Could you provide a sample project that reproduces this issue so that I could take a closer look?

Hello nesrak1,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will follow up.


I don’t know what fixed it but I’m not having this problem anymore.

I am happy to hear that your issue has been resolved. If the issue returns please feel free to reopen this thread with any additional information you may have and I will be happy to assist you further.

Make it a great day