Failed to open descriptor file error

I have a blueprint only project that when I package as a “shipping” build and try to run the .exe located in the WindowsNoEditor it opens with a dialogue box saying:

"Failed to open descriptor file.
‘…/…/…/TowerDefence-Win32-Shipping/TowerDefence-Win32-Shipping.uproject’

It happens for 32 or 64bit.

A development build runs fine, I’ve not had any issue with 32 or 64bit when packaging a development build.
I’ve also tried it on multiple computers both with and without Unreal Engine, I’ve tried packing for distribution and that didn’t work either.

Any help is appreciated.

Hi Haigen

I see exactly the same behaviour - if I run the build on a network share. If I copy the entire built directory structure to a local location on my machine (such as my desktop) it runs normally. I’d be interested if you are seeing this same behaviour - which I would like to know the reason for.

Hey Haigen,

I was unable to verify this happening on the Strategy Game project available from the Epic Games Launcher or a full blueprint project. Could you please attach your logs you should find them in a similar location as D:\MyProject6\Saved\Logs

Thank you!

Here is my log:

https://dl.dropboxusercontent.com/u/95557696/TowerDefence.log

if there is anything else that can help let me know.

Did you obtain UE4 from Github? Or are you running UE4 from the Epic Games Launcher? Also, how do you typically package your project? Please provide all steps necessary.

If you’re building from source, here is some documentation you can review.

Looking forward to hearing back from you, thanks!

I use the launcher.

I package my project with the following settings:

Can you try going into the WindowsNoEditor/Engine/Binaries/Win32 and run UE4Game-Win32-Shipping with TowerDefence as your command line? (or maybe …/…/…/TowerDefence/TowerDefence.uproject)

Make sure that works. I think there may be a problem with the bootstrap executable (the one in the root of the WindowsNoEditor dir just points to the one in Engine/Binaries/Win32)

Josh

This worked! Thanks, I created a shortcut and added …/…/…/TowerDefence/TowerDefence.uproject onto the end after the .exe in Target.

Wonder why this occurs?

Can you please be more clear about what exactly you did. What shortcut did you add as command to what Executable? Don’t really understand seeing how you are using the names of your project and locations.

Per Josh’s response, go to: WindowsNoEditor/Engine/Binaries/Win32 and run UE4Game-Win32-Shipping with …/…/…/TowerDefence/TowerDefence.uproject after the .exe in the Target line.

Somebody else suggested going into the /bin directory and change the exe name to not include ‘-win32-shipping’ - EG: make sure its the actual name of your project. That worked perfectly for me.

WTF, renaming worked also for me… But now the EXE in the root dir crashes:

http://i.imgur.com/msvNBON.png

Does the EXE in the binaries-subfolder install the “UE4PrereqSetup_x64” as well if needed?

Hey Vehrym,

Did renaming the file help with your issue as Schubboy and Spyro have suggested?

Thanks for assisting! :slight_smile:

It’s works! Thanks a lot!

Can you show an example or printscreen, I don’t understand anything of your solutions, I don’t have the folder “Win 32 or 64” in \Engine\Binaries…, I have the folder “ThirdParty” Only. Thanks for your time.

Second that. Getting this error on windows 7 when trying to run packaged game

Please attempt the work around for this issue as stated above. If that does not work, please provide a screenshot of the error that you’re receiving and exactly how you packaged your project.

Thank you.

I’m getting the same error with a shipping build (with full rebuild and pak Enabled), I’ve tried Spyro’s fix but get the same error message. I’m using my own game and not the tower defense demo so i have no idea how to appropriate apply Josh’s idea :confused:

I’m having a similar problem but I don’t have any folder inside of Engine\Binaries\ other than a ThirdParty folder. Any help would be appreciated have seen this on multiple projects currently using version 4.9.2.

Hey Jmullens88,

Could you please describe exactly what is happening with your project, whether or not you’re using a blueprint or c++ project and if you’re on a source or binary version of the engine.

Looking forward to hearing back from you, thanks!