Download

"Failed to open descriptor file" error while trying to open standalone .exe (packaged)

See the image:a6d843c3894dc4a1bbec06317579dfe1ed406fd8.jpeg

I also tried searching why this happens in this forum but no concrete answer.

-do you get the same message when you package with the “development” + win32 settings?
-which engine version do you use?
-report it on answerhub -> https://answers.unrealengine.com/ (I have seen this problem serveral times, but never heard of a solution -> might be a bug) :slight_smile:

1- No but gives another one, see image below.
2- 4.8.6
3- Ok

I dont see a valid reason for this error to occur as i when i hover on to the packing option for windows 32 bits it says “build, COOK and package your game…”
5273fca34de985a0a8a39b864120f9c2c0bdbb40.jpeg

Also i dont know if this matters but i can run the game by clicking in the smaller file under WindowsNoEditor folder usually named MyProject.exe

I’m surprised Epic hasn’t fixed this yet.

I still haven’t found a legitimate answer and it’s been MONTHS.

~ Jason

So im stuck with only me playing the games i make? Am i actually opening the right file?

I’ll try packaging a game and test out the myproject.exe when I can.

As far as I know, this error has no fix so if you find something to make it work go for it.

~ Jason

I’m abel to package my games without the error -> would it be possible that you could send me the .exe file so that I can see if I also get your problem? :slight_smile: + have you already reported it on answerhub?

I really wonder why this error is only happening to select people.

It seems strange that it’s not a universal thing.

~ Jason

Yep, that’s why it would be cool to get an official statement from epic about this problem :smiley:

thanks for the answers, yes i already reported to answerhub
here is the link if you want to test. both shipment and dev .exes are there.
https://www.sendspace.com/file/rne5l7

Well without the actual project files it’s hard to tell since the development build won’t run…

However, the shipping version is giving me the error, but I don’t know if it’s because in this case something really is missing.

~ Jason

Fighter!

Use your speech skills to convince Epic to fix this problem.

I’m trusting you with this.

Now don’t disappoint me!

~ Jason

To test this on our end we need the entire packaging folder, not just the .exe (the “windowsnoeditor” folder) :slight_smile: + open the game with the .exe that you can find in the root folder, not the one under engine-binaries-… (this should fix your problem)

They are surely already trying to solve the problem, otherwise I will try my best to find out why this is happening :smiley:

oh so im not supposed to open in under binaries? the whole windowsnoeditor folder weights about 800mb, thats for a simple first person game from the start packs
even though when i open it under the windowsnoeditor folder it works, i cant imagine how big a decent game would become? or the size wouldnt change too much compared to this one?

Before you package something, always make sure that you delete all unused content -> e.g the starter content. This will reduce the package size :slight_smile:
I dont know why there is still a .exe in the binaries folder (this has changed with 4.6) but just use the one in the root and everything should be fine

now i got about 350mb with no compression.

Does that sound right?

It depends on what exactly you use :slight_smile: -> just a packaged game which uses the fps template, will have around 350mb

yeah i understand that, just wanted to know if my output was averaging the same as everybody if used same settings and same content in game.

Thanks for your answers fighter5346 and Jason Wandered, you guys were really helpfull.

Have a good dev day

So maybe I missed it but how did you fix it? I have the same problem but cannot get it to work as well. Same error so I would love to see how it got fixed.

Instead of opening the .exe in the binaries folder, you have to use the one in the root of your folder :slight_smile: