Download

"Failed to open descriptor file" error while trying to open standalone .exe (packaged)

I tried that but did not work. I am looking through other options and will post back if something works. I found a lot of people on answer hub trying different things so I hope one of them works.

Yep, unfortunately there is no “real” solution for that problem (hopefully epic games will fix this type of error) -> meanwhile just try all solutions that you can find on the internet :slight_smile:

I agree with you. I am stuck and I have no idea how to fix this. I tried several different options but got nothing. I am going to try and see if it is possibly a packaging setting I have set wrong.

anyone found out a turn around for this? I made something for Ludum Dare and this error screwed me badly! Stop wasting time on 4.9 and pls fix this!

Have you already tried the suggested “solutions”? -> otherwise make sure to report it on answerhub or try to package it on another pc

I have found this in the past 24 hours:

Changing the name of the /bin/ exe to “yourproject.exe” rather than win-32-shipping.exe is a work around, not mentioned here. Also; 4.9 have made my project work, and could build it.

This error carriers from project to project, I tried in several PCs and got this error.

And yes; I tried all those suggestions. Didn’t work either, still ty! Got it solved on my own :slight_smile:

Glad you found a solution. For the benefit of others, here’s an AnswerHub post that also helped some users: Failed to open descriptor file error - UE4 AnswerHub

Sorry for bringing up this thread again, but I have the same problem now on two machines. Suddenly, building worked fine before. I use the binary version (4.9.2).

I create a new project and build a shipping build: I get the error message with the descriptor file.

Development build works fine.

What I found out that if I do this the shipping build runs fine:

  • use \windowsnoeditor\projectname.exe of the development build
  • replace the shipping build exe with it
  • rename the \windowsnoeditor\projectname\binaries\win64\projectname-win64-shippingbuild.exe to …\projectname.exe

so… I THINK it is a problem with the \windowsnoeditor\projectname.exe starter executable. Would that help narrowing down the root cause of this error?