Failed to load package on client

I’m working on a multiplayer game with simple matching (players hit join from the main menu and I just pick a random game out of the list I get from SearchSessions) using the Null OnlineSubsystem (so LAN only at the moment) and I’m having issues loading the correct level when I load join a server. I’m using ServerTravel on the host to load the level I want to play and when the client joins it attempts to load the correct level but I get the following error in my output log:

LogNet:Warning: Travel Failure: [LoadMapFailure]: Failed to load package ‘/Game/FirstPerson/Maps/UEDPIE_0_FinalLevel’

LogNet: TravelFailure: LoadMapFailure, Reason for Failure: ‘Failed to load package ‘/Game/FirstPerson/Maps/UEDPIE_0_FinalLevel’’

It then just loads the default level. I have this problem regardless of whether I try PIE, Standalone Game, or Launch (I did notice that when I Launch the game the build it puts in Saved\StagedBuilds doesn’t contain FinalLevel at all).

Any ideas on what the problem might be?

Hi kgamble,

How are you having the client join the server? Are you using Blueprints or C++? If you’re using C++, calling ClientTravel will automatically load the same level as the server. If you’re using Blueprints, the Join Session node will automatically call ClientTravel in its implementation, so you shouldn’t need to load any levels explicitly on the client.

There are some known issues with ServerTravel during a PIE session that we hope to fix in a future version. What is the log output when you try to connect using Launched instances (for both the client and the server)?

I’m just using the Join Session node, never explicitly call ClientTravel (don’t think that’s exposed to BP anyway).

It seems I was mistaken and my launch builds aren’t able to connect at all, the client just gets a timeout then loads our default level. The relevant log output for the server:

[2015.03.19-20.56.48:237][ 32]LogEngine: Server switch level: FinalLevel?Game=/Game/FirstPerson/Blueprints/GameModes/FreeForAllGameMode.FreeForAllGameMode_C?listen
[2015.03.19-20.56.49:254][ 32]LogPackageName: SearchForPackageOnDisk took   1.016s to resolve FinalLevel.umap
[2015.03.19-20.56.49:254][ 32]LogNet: Browse: /Game/FirstPerson/Maps/FirstPersonExampleMap
[2015.03.19-20.56.49:254][ 32]LogNet:Warning: Travel Failure: [InvalidURL]: Invalid URL: /Game/FirstPerson/Maps/FirstPersonExampleMap
[2015.03.19-20.56.49:272][ 32]LogNet: TravelFailure: InvalidURL, Reason for Failure: 'Invalid URL: /Game/FirstPerson/Maps/FirstPersonExampleMap'
[2015.03.19-20.56.49:272][ 32]LogLoad:Warning: UEngine::TickWorldTravel failed to Handle server travel to URL: FinalLevel?Game=/Game/FirstPerson/Blueprints/GameModes/FreeForAllGameMode.FreeForAllGameMode_C?listen. Error: Invalid URL: /Game/FirstPerson/Maps/FirstPersonExampleMap
[2015.03.19-20.56.49:272][ 32]LogNet:Warning: Travel Failure: [ServerTravelFailure]: Invalid URL: /Game/FirstPerson/Maps/FirstPersonExampleMap
[2015.03.19-20.56.49:272][ 32]LogNet: TravelFailure: ServerTravelFailure, Reason for Failure: 'Invalid URL: /Game/FirstPerson/Maps/FirstPersonExampleMap'
[2015.03.19-20.56.49:307][ 33]LogNet: Browse: /Game/FirstPerson/Maps/FirstPersonExampleMap?closed
[2015.03.19-20.56.49:307][ 33]LogNet: Failed; returning to Entry
[2015.03.19-20.56.49:310][ 33]LogLoad: LoadMap: /Game/FirstPerson/Maps/FirstPersonExampleMap?closed

And the output for the client:

[2015.03.19-20.57.12:517][510]LogScript:Warning: Found a session. Ping is 298
[2015.03.19-20.57.12:517][510]LogBlueprintUserMessages: Kelby-HP-3A82A0F646E680A9FC29D7B31C41618B
[2015.03.19-20.57.24:752][715]LogNet:Warning: UNetConnection::Tick: Connection TIMED OUT. Closing connection. Driver: IpNetDriver_0, Elapsed: 60.050762, Threshold: 60.000000, RemoteAddr: 10.1.10.12:0, PC: NoPC, Owner: No Owner
[2015.03.19-20.57.24:752][715]LogNet:Warning: Network Failure: PendingNetDriver[ConnectionTimeout]: UNetConnection::Tick: Connection TIMED OUT. Closing connection. Driver: IpNetDriver_0, Elapsed: 60.050762, Threshold: 60.000000, RemoteAddr: 10.1.10.12:0, PC: NoPC, Owner: No Owner
[2015.03.19-20.57.24:752][715]LogNet: NetworkFailure: ConnectionTimeout, Error: 'UNetConnection::Tick: Connection TIMED OUT. Closing connection. Driver: IpNetDriver_0, Elapsed: 60.050762, Threshold: 60.000000, RemoteAddr: 10.1.10.12:0, PC: NoPC, Owner: No Owner'
[2015.03.19-20.57.24:752][715]LogNet: UNetConnection::Close: Name: IpConnection_0, Driver: PendingNetDriver IpNetDriver_0, PC: NULL, Owner: NULL, Channels: 2, RemoteAddr: 10.1.10.12:0, Time: 2015.03.19-20.57.24
[2015.03.19-20.57.24:752][715]LogNet: UChannel::Close: Sending CloseBunch. ChIndex == 0. Name: ControlChannel_0
[2015.03.19-20.57.24:752][715]LogNet: DestroyNamedNetDriver IpNetDriver_0 [PendingNetDriver]
[2015.03.19-20.57.24:752][715]LogExit: PendingNetDriver IpNetDriver_0 shut down
[2015.03.19-20.57.24:811][716]LogNet: Browse: /Game/FirstPerson/Maps/FirstPersonExampleMap?closed
[2015.03.19-20.57.24:811][716]LogNet: Failed; returning to Entry
[2015.03.19-20.57.24:870][716]LogLoad: LoadMap: /Game/FirstPerson/Maps/FirstPersonExampleMap?closed

Based on the server log, the server itself is failing to travel to the new map. Since this failed, the server is never opening a map with the ?listen option, so it won’t be able to respond to any clients that are trying to connect (this is why the client is timing out).

The “Launch” button in the editor will only cook the current level that’s open and save it in the Saved/StagedBuilds directory, which could explain the travel failure.

One more thing to try is using the Package Project option. This will cook all the levels in your project, and should allow the server to travel to any of them.

For people have this issue what i found was that i renamed the map thats giving that error and i forgot to change it some where else in my blueprints for some reason it worked in the editor but not in standalone etc

I FINALLY FOUND OUT WHAT’S WRONG!!! (Sorry for caps, but this is big for me right now)

Go to Edit > Project Settings > Packaging. Then click on the dropdown arrow under the packaging section.
List of maps to include in a packaged build.
Add as many elements as you have levels you want to load.
And add your levels from their directory.

NOTE:
If you can’t find your Levels, right click them in the content browser, Show in Explorer.
You may need to uncheck read only on them in the explorer.

Praise the Sun!

Got this error after changing map directory. Moved it back and all work fine.