Failed to compile on project creation

When I create a project (tried basic code and first person) I get a compile error when the project is being created.

“The project failed to compile with this version of the engine. Would you like to open the project in Visual Studio?”

Here is the build log:

The project failed to compile with this version of the engine. Build output is as follows:

Running C:/Program Files/Epic Games/4.7/Engine/Binaries/DotNET/UnrealBuildTool.exe MyProject23 Development Win64 -project=“C:/Users/Sean/Documents/Unreal Projects/MyProject23/MyProject23.uproject” -rocket -editorrecompile -progress
Parsing headers for MyProject23Editor
Reflection code generated for MyProject23Editor
Performing 10 actions (4 in parallel)
[2/10] Resource ModuleVersionResource.rc.inl
[3/10] Resource MyProject23.rc
C:\Program Files\Epic Games\4.7\Engine\Source\Runtime\Core\Resources\Windows\ModuleVersionResource.rc.inl(3) : fatal error RC1015: cannot open include file ‘windows.h’.

C:\Users\Sean\Documents\Unreal Projects\MyProject23\Source\MyProject23\Resources\Windows\MyProject23.rc(8) : fatal error RC1015: cannot open include file ‘windows.h’.

C:\Program Files\Epic Games\4.7\Engine\Source\Runtime\Core\Public\HAL\PlatformIncludes.h(5) : fatal error C1083: Cannot open include file: ‘new’: No such file or directory
-------- End Detailed Actions Stats -----------------------------------------------------------
ERROR: UBT ERROR: Failed to produce item: C:\Users\Sean\Documents\Unreal Projects\MyProject23\Binaries\Win64\UE4Editor-MyProject23.dll
Cumulative action seconds (8 processors): 0.00 building projects, 0.39 compiling, 0.00 creating app bundles, 0.00 generating debug info, 0.00 linking, 0.00 other
UBT execution time: 12.16 seconds

I am using windows 8.1 with the SDK for 8.1. I was using Unreal Engine 4.7.4. Now 4.7.5
I am using Visual Studio 2013

I tried reinstalling the engine but that didn’t work. 4.7.5 did not fix the issue.

Also tried uninstalling visual studio and the engine. Reinstalled visual studio then the engine and still get the same problem.

Found a solution to this.