Failed to build C++ code files in 4.10

Hi all,

I’m using Unreal Engine 4.10 in Linux with Kdevelop. I’m following the Twin Stick Shooter tutorial and after writing the first source codes I cannot build the project using the IDE.

This is the error messages:

/home/giang/Programs/UnrealEngine>make -f Makefile UE4Editor UE4Game ShaderCompileWorker UnrealLightmass UnrealPak
bash "/home/giang/Downloads/UnrealEngine"/Engine/Build/BatchFiles/Linux/Build.sh UE4Editor Linux Development  
Makefile:188: recipe for target 'UE4Editor' failed
bash: /home/giang/Downloads/UnrealEngine/Engine/Build/BatchFiles/Linux/Build.sh: No such file or directory
make: *** [UE4Editor] Error 127
*** Failed ***

This is the screenshot:

Hey Tống Tùng Giang-

I’m not sure what is causing you to get this message. Can you let me know if you get the same message when you create a new code project and try to compile it without adding anything to it? Additionally, after saving the .h and .cpp for the Twin Stick project, can you open the project in the editor and use the in-editor compile button and let me know if that succeeds/fails and what message you get if it does fail?

Cheers

Doug Wilson

Hi Doug Wilson,

I’ve changed into CodeLite, because it has better tutorial provided by yaakuro. It worked successfully.

Before doing that, I’ve tried compiling with Kdevelop/QT Creator but I haven’t tested on the in-editor compile button. I think in my case CodeLite is a better solution than Kdevelop. :smiley:

Ah one more thing, since the problem has been solved, can you please mark it for me, I can’t find the button. T_T

Cheers,