"Failed to add class x. Failed to generate project files."

I created the “top down” C++ project, went to File / Add Code to Project, selected WorldSettings, typed in “WorldSettingsX” as the name, and got “Failed to add class WorldSettingsX. Failed to generate project files.”

What causes this?

I’d thought perhaps I’d accidentally left the project open in Visual Studio separately, but VS was not open.

This seems to occur with any type of object I try to add, such as Pawns.

What am I doing wrong?

My normal workflow is to run the Editor from VS, and add new code from the Editor. So, I believe it is supposed to work with VS open. Was Rocket installed after VS?

No, I installed it after VS.

It seems to work with a different project, but not with that particular one. I’m not sure why … I was able to add classes to the FPS example, but not to the top down one.

Hey Paul,

Would you mind sending us the project if there hasn’t been a lot done to it; non-specific things? Just zip it and put in on the FTP or you can mail it to me at Ryan.VanEnkevort@epicgames.com

Best Regards,


Perhaps try doing a full code recompile from Visual Studio express?

I have steps and pictures on this below

Let us know if any issue remains after successful full code-recompile

Compiling C++ for UE4


Thanks, Rama – That still doesn’t fix it. It seems to be something with that particular project; I created a new one based on the FPS example and I was able to add classes to that one.

My project is based on the TopDown Template.

Oddly, it worked for me after I created a whole new project based on the Top Down template.

So, presumably, there was something I’d done to that project that caused me to be unable to add new classes to it. I am wondering if anyone knows:

A) what I’d done to cause the problem,
B) what the error means, and
C) what to do to salvage a project if I come across the error again.