Fade emissive material

I have a completely dark world, and am lighting it up with emissive materials. Essentially, I want to be able to draw a gradient on the ground, but this has proven quite a challenge. I have tried making the color nearly black, and also adjusting the color’s alpha. Neither work.

What is the best strategy to get this to work? I thought I may be able to light the world but just make nothing react to light unless I wanted it to, but it looks like this isn’t possible.

Thanks in advance!

Hi Lukefwilson,

If you provide some more details about how this would work I can suggest some approaches. Currently I am not sure what type of gradient you are looking for so I am not sure what to suggest.

Emissive materials should be able to cast light into your scene using lightmass just fine, but I am not sure what you mean by wanting to draw a gradient. Do you mean to define the shape of the emissive part of the material? Are you wanting to animate this somehow? It might be a challenge to ‘reveal’ the lit world along with the emissive but if you mean the world is completely black until then, it makes it easier.

Hey Ryan! The only reason I’m using emissive is so that I can make everything else black, and just see what is drawn in the texture. The issue is that I want to be able to draw gradients on that ground (and eventually animate them) . The problem is that emissive materials never look dim, no matter how dim I try to make them.

The effect is to visualize echolocation. The world is traced by the sound waves, and I only want to be able to see what the sound waves are “lighting up.”

You also answered another question of mine: Remove lighting. All materials - Rendering - Unreal Engine Forums. Would that approach be a good way to solve this problem?

Yes sure. I was mostly asking what ‘shape’ you wanted the gradients to look like so I could suggest how to start it out.

I am not sure why the emissive never looks dim. Try disabling eye adaption. It is likely that ultra dark scenes are causing eye adaption to crank brightness way up. You can disable it under view (bottom of menu has exposure, set to 0). or by making a post process volume where “min” and “max” under eye adaption are set to 1.

Also “dim” might need to very low. Try multiply by numbers like 0.05 and see what that looks like.

Awesome! Between fixing the exposure and using an exponential gradient rather than linear, it’s beginning to look like how I imagined. Thanks!