Download

Faces in shadows are colored as the color defined in Blender

Hey.
As the title says I got problems with my meshes that I imported from Blender.
In Blender I made the materials, named it after the texture and gave it a random color, so it’s easier to know the different textures in Blender.

When I import it all to UE4 and build the lighting, then this happens:
HighresScreenshot00030.png
(focus on the buildings).
The faces in the shadows got a greenish colored shadow.
The grass texture below doesn’t reflect it as I tried to move the house to a place with no other meshes nearby, and it still had the shadow issue.
The material is this:
0a8bc4435fba96db0300d6dd1aaf33fdfee0b9b0.jpeg
Before I added the texture it had a 3 vertex with the same color from Blender. I deleted that and add those nodes.

The shadow is the same color as the material color in Blender. Greenish.
The materials shouldn’t emit colors or something.
Anyone who knows what the problem is?

Last time I saw this, we fixed it with building the light in “production” quality + adding a lightmass importance volume :slight_smile:

Don’t set specular to 0. Default is 0.5 and it’s supposed to work for pretty much all materials.

I changed it to production and it helped it much, but still got a little bit of green in it. It seems like the lightmass importance volume doesn’t do anything, or maybe I’m doing it all wrong?

Didn’t change anything other made some materials getting glowly, which looked unrealistic.

Hi QuickisQuick,

Check you Sky Light and make sure that the Light Color or the Occlusion Tint has not been changed to green.

Also, check Settings > World Settings > Lightmass > Lightmass Settings > Environment Color and set this back to default black or light gray as well.

If you’re still getting the error, can you try a new default map or template project (fps or third person) and see if you get the same results.

This appears to be one of the settings I’ve mentioned above causing the issue.

Let me know.

Tim

The settings are set to default, so they got the same settings as you recommend.
I tested the same mesh in another project and it doesn’t have the greenish shadow.
Settings are the same, so nothing has changed.

After investegating alot more it looks like it’s reflection lights. The green color on the wall must come from the grass below, as it got the same color as the shadow.
Another example is this.
HighresScreenshot00040.png
The crates don’t have their original material color as yellow, but green. The roof had a yellow color before I applied the texture.
It seems like the mesh itself gets the color of the material in Blender baked into the mesh itself, which then means the color will be more visible. It’ll then emit the light to other meshes, which the new pic demonstrates.

Is there a way to block it from sending the colors?

Anyone knowing anything?

Hi Quick,
can you give me a link to a basic model, then i can look at it in blender.
Greetings
Edit:
Some Things.
You have empty UV Maps on layer one. Select all faces to see, there is no unwrap in the Image editor Window.
Make one.
I think the problem is "You only need to use one UV channel for Base Color, Roughness, Normals, and other Material related properties. " UV map is empty, the mighty tool uses material color.
Try to make one object into one single FBX and reexport.
You have to set the origins for better use in UE4, search for origin in https://wiki.unrealengine.com/Static_Mesh_from_Blender#Exporting
It is no Problem for Blender, to render a whole scene with many objects, but if it comes to exporting, you need something like this – https://forums.unrealengine.com/showthread.php?43740-Blender-to-Unreal-FBX-Batch-Export-Static-Mesh-with-Collision-Help
I export every single object as fbx, to locate errors quick. sometimes faces need a wrong looking facereorganisation, when you work with singlesided open meshes.
Next Edit:
Select one Object (first front building walls)Press Ctrl+i (inverse selection), then hide with h.(alt+h if want to unhide).
Now select your walls, press tab, switch to facemode, select frontface, near window. Its not welded.
Reorganize your meshstructure to complete parts, they are splittet in different, unregular parts.
http://wiki.blender.org/index.php/Doc:2.4/Manual/Modeling/Meshes/Editing/Vertices
Join meshes with strg+j, seperate faces with strg+p.
I hope that could help, forgive me rusty english.
Best regards Stefan :slight_smile:

After playing around with a few settings, then I got a little better result, but still not the result wanted.
HighresScreenshot00041.png
The yellow color is now gone from the crate, which I made possible by changing “Num Indirect Lighting Bounces” to either 1 or higher than 3. Setting it to one made the rooms in the buildings glitch out with strange lighting.
I later then flew around and checked the place, where it always happens, and surely it still happens.
HighresScreenshot00042.png
HighresScreenshot00043.png
As you can see at the above images, then it’s green in the shadow only. The crates aren’t affected anymore, and it looks like it’s only that brick material and the meshes.
world_settings.png
The settings are default, and the skybox too, so it can’t be caused by that either.
But further back at my map this highhouse also stand in the shadows, but it isn’t green, and it got the color I want it to be.
HighresScreenshot00044.png

This makes me suspect that it’s something to do with the meshes itself, and not something global. Idk if the “Num Indirect Lighting Bounces” removed that option, but it doesn’t happen elsewhere.

If I move the mesh away from it all it looks like it loses the color, but turns completly black. It might be because it’s not having any light shining on the surface, but idk.
HighresScreenshot00045.png
Also another demonstration:
HighresScreenshot00046.png

I also tested the same meshes in another project (1st person) and it gives the result of the very first screenshot of this topic.
HighresScreenshot00000.png
Please note that I haven’t done the shadows in detail and I only applied the material of the mesh.
As you can see nothing changes and therefore it must come from the mesh or something.

I’m soon running out of ideas, and this might turn out to be a project to give up on. Anyone knowing what is causing it?
I really love all the support given, and I hope that I can find a solution for this problem.

Well if all else fails it’s time to divided the trouble shooting down to find where the problem might be.

You seem to have covered most but for completeness.

It could be in the lighting.
It could be in the source chain from Blender imported into UE4
It could be in the material set up.

The bast practice as to trouble shooting is to split it in half as to what you know should work and what you might suspect is the problem,

In the same project start up a new blank map with the basics. Drop your building that’s causing the problem into the center and added a default material or one you know works and then build the lighting.

If it’s messed up then you know it’s in the source chain.

Next add your material and rebuild.

If it’s messed up then the problem is in the material and to figure out which is causing the problem you can disconnect links one at a time. If you disconnect the normal map, which can cause strange effects, then there is you problem. (note materials don’t always jive as to what you see when applied)

So in a clean room so to speak if it all checks out you just crossed off half of what the problem might be and time to eliminate the other half.

(P.S. If everything checks out you might as well continue to work with the rebuild)

Back in the project map kill off anything that directly effects the light solution. Direct lights, point lights, sky lights, reflection spheres, post process, with the only thing left being light importance.

Note light importance only limits the lighting solution to whats in the box so it saves rendering time of not having to do the entire environment. (ie compile goes from 1 hour to 1 min kind of thing).

Put new fresh single sky or directional light in the environment and build your lighting. If the problem is gone then your light set up was the problem. If not then there is something wrong in the project settings.

The thing of it all is to figure on what side of the fence the problem is originating and could be occurring in the source chain or in the project file so until you figure that out it’s just guessing.

By the what format are you exporting to? I use 3ds Max so I know it all works but Blender has had issues with FBX, which I “heard” was fixed, but their obj exporter I know for a fact does not play nice with other 3d applications.

Last tip don’t worry to much about it. :wink: 99.9% of the time if I have some kind of issue I usually land up banging my head on the key board as it turned out to be something simple so your not the only one that’s been there and done that.

The wall only gets green in the shadow, when it’s near other objects. In the new level it passed all tests, so it had to be the project settings. In my map I removed all the lights and all the faces on the building got green, except near the boxes, where it apparantly had light, as it was normal there.

Idk if I did the test properly, but I still don’t know where the problem lays.
It has to be in either the lighting or the project settings.

I wondered if this might be caused by having a SceneCapture object embedded in a wall?

Still investagating the issue.
Here are some screens from the testing yesterday:
HighresScreenshot00053.png
HighresScreenshot00052.png
HighresScreenshot00054.png

Today I then looked around on my map, and I found this place:
HighresScreenshot00051.png
The backwall isn’t green, while it’s in the shadows. The same shown on the pic with my highhouse, where it doesn’t have that color either.
Though the pole faces facing the grass is green.

The mesh or the material must be sending its color out to the rest of the map, where the black faces of the brick wall will get the color. Is there a way to block that?

Have you welded the loose vertices in your models, like i told you?
In the moment your meshes only made from exploded/unwelded faces.
I bet it was made through duplicating faces and scale them with snap, but then you get ugly ngons and nothing is welded.
I still can see the same wrong faceorga in the doorframe.
Try to uvmap a single object, not using the whole map, unwrapped outside bounds.
Made you the map, or is it an extraction?
Why not modeling a fresh single house in the right way and export it, to limit errors?
Forgive me worst case rusty english.
You told me that the map is from GTK radiant, perhaps something is not ue4 compatible.
When you try to export a box in that style, where every side has only one face, it could working, aside some lightning issues, but it still would be wrong.
greetings
Edit: Inside UE4 you could easy build that sort of buildings with bsp brushes and export them into blender for example, to remesh and weld them.
“Sometimes” it is needed to optimzie mesh or UV, perhaps only to put in a second uvlayer for nice lightmapUvMap.
Name every single part, which should have specific materials (doorframeMat, WallBricksMat,…) end reexport them into UE.
Then you can very easy apply materials onto mesh and all is working, like expected(most times ^^).

Can you upload the project file some place and I’ll have a look see?

If you removed any environment effect that would add green it’s starting to sound like something is broken inside the asset chain or something outside of Unreal 4.

The project file is quite big. Will find it hard to upload it quickly. Will try anyway

Took a look and there is a few easy to fix problems.

  1. Your light map resolution per static mesh is to low (set tot default 64) so this is preventing your shadows from being fully formed or generated into the light map at all. If you select the static mesh there should be a resolution over ride and should be changed to a value that gives the asset the most amount of coverage. For testing to see if you can dial it in change to 256 > 512.

Note this will increase light build time if you make your light maps to big per object so only use high values to test that it’s working.

  1. The green surfaces is being caused by the renderosity effect of the directional light bouncing off of the hill side and splashing off the back face of the building. This is actually a normal effect of the directional light as to the number of bounces. To mute the effect you need to control the over all environment lighting as to indirect lighting by adding a sky light.

By changing the intensity of the sky light or decreasing the directional light you should be able to get a good balance between indirect light and light bounce.

More than anything though your landscape is one big sheet of green so if you paint it properly that should get rid of 99% of your problem.

Thank you so much for your help!
HighresScreenshot00074.png