face normal probleme

Hello everyone, I have had massive problems with invisible faces since version 4.18. I didn’t have that before. My assets come from blender. The problem seems to be arbitrary. I am using version 4.25. There doesn’t seem to be any answer other than normal alignment. That’s not it. Why are parts of fbx models coming from Blender strangely translucent, twisted? Greetings.;base64

What are the export settings in Blender (1-2 screenshots please)? The coordinate system in Blender is different from Unreal:

Blender = Y is vertical up, -Z is forward facing camera axis
Unreal = Z is vertical up, -X or X is forward facing camera axis (unsure which exactly)

This can be changed in the Export settings on export of an .fbx. Actually, those coordinates in Blender are for FBX, not just Blender, from what I remember. There’s a few other settings too. I know it can be changed in the Unreal import settings on import by selecting “Convert scene” or something similar, but it might work to change it in Blender first. The other settings are to do with whether properties added to the model in Blender are retained during export, smoothing groups applied or not, and several others that are important for maintaining the model from Blender to Unreal. The issue might also be how UE got a new pipeline for export/import, and probably certain things that are not automatically processed anymore when importing, so those need to be set in the export program, in yours and my case it is Blender.

First of all, thanks for the answer.

Of course, I know all of the standard settings. I’ve also been working with blender for almost 10 years. Massive problems have occurred since version 4.19. Objects lit up and cast a shimmer on the wall. Objects were always transparent or semi-transparent from one side, despite their normal orientation and doublesided material. Objects that were mirrored in blender with the mirror tool were black, etc. I will now download version 4.18 because I am now at the end of my ideas. Objects that are contained in blender circles during modeling shine according to lightbuild. Really weird. Sorry for my english, i use google translate. Greetings.;base64

you probably changed from mickt normals or something similar in your import settings.

I use blender daily… not a single issue across a multitude of meshes. Skeletal, static, alembic, gltf, they all work as intended 100%.

the issue must be either export or import.

I’ve tried everything that a non-professional can use in terms of settings. I have now tried the 4.18 again. Not the slightest problem. Only the walls sometimes have thin black lines after the light build. I’m trying version by version. 4.24 and 4.23, the same problem. I had the problem with my Gigabyte notebook, my alienware and now with the Razer blade Pro. I have to go to many. The normal problems, if they are any, I don’t have with 4.18. They are the same meshes, the same settings. The problems started for me from version 4.19. Greetings.;base64

Can I send my FBX file to someone? Created in blender 2.9. Textures created with cyles nodes. Many thanks.;base64

I’ve been able to solve the problems so far. However, one thing remains that I consider to be a bug.
Objects that are duplicated in blender and then mirrored with Ctrl + M are displayed incorrectly in UE after being imported.
Reverse culling, two sided material, recompute normals etc. does not help. Depending on the viewing angle, the object has no front. You can almost see into the mesh.
If I turn the mesh in the blender manually, that doesn’t happen. Unfortunately, sometimes the geometry requires it to be mirrored.
After the light build, these objects are pitch black. If I activate -two sided materials-, the objects are only displayed correctly in the viewport. greetings;base64

Send your fbx to me. I have Blender 2.9, so I’ll check it in there and try importing to Unreal 4.25.3, and 4.24.3. I’ll try doing a mirror in Blender and then import to Unreal too. I’ve seen a problem before with mirroring in Blender and importing to Unreal, in another thread, and it was with a pre-made mesh. I don’t recall the fix that solved the problem, but if I’m capable of finding the thread, I’ll post a link to it.

Hello Presto 423,

I’m sorry I haven’t contacted you for so long. I don’t usually use the forum. I solved the problems. As already said, the problem with the mirroring of objects in blender with Ctrl + M. Objects become one-sided transparent in the UE. After lightbuilding they are black. Maybe not with simple objects like cubes etc., but with relatively complex modeled objects. They have to be rotated manually with R + the corresponding axis + degrees. greetings;base64