Exynos GearVR Support

I’m running a rooted Note4 with Android Lollipop 5.0.1 on an Exynos GearVR phone. I can’t get Unreal 4.7.2 (binary build, haven’t tried building from source.) to work for the GearVR. GearVR applications from the Oculus store works great. I can build Unity games for the GearVR just fine.

The issue I’m getting is on the C++ first person template it seems to render each eye correctly then it stops rendering. No headtracking, and if you fire the gun using the GearVR touchpad it doesn’t render in game. You can hear the sound of the gun firing. I’m able to do a non GearVR android build, the touch controllers appear and I can run around fine in the level, so UE4 is definitely capable of rendering to this phone for a normal android game.

I’ve tried following all the suggestions in this thread: Epic's low priority on GearVR and VR in general makes me sad - XR Development - Unreal Engine Forums

I have a oculussig file correctly setup (it works fine doing Unity), and followed all the steps to get GearVR working (plugin enabled, scalable3d mobile content, no starter pack, configured for android properly, remembered to check Configure the AndroidManifest for deployment to Gear VR = true, etc.

Does anyone have any other ideas? How long would Exynos support take?

Link to the firmware I’m using for my rooted Exynos note 4:



If I take off the headset and put it back on it resumes rendering for 2-3 seconds and lets me head track before the render thread freezes.

I’m the same situation…

Exynos GearVR support is now official in the latest 5.0.1 lollipop firmwares. If this has not been released in your region yet or you used the early 5.0.1 Polish firmware in February then you will need to update to a newer 5.0.1. any of them with a build date around mid-march or later are working! :slight_smile:

You can get the latest official firmware for your device from here:

Just grab a different region if yours is not a 5.0.1 build from mid-march yet :wink:

UE4 rendering fine then :slight_smile:

Good to know. Is there any reason for it not to support KitKat? All other VR apps work fine. In the meantime I’ll just wait for lollipop.

On my N910U on 4.4.4 I’m getting this rendered even though I’m wearing the GearVR:

Thank you! Upgrading my firmware to that release lets me run UE4 on Exynos.

Hello Rimig88, i am gear vr developer for ue4. I’m the same situation,how to solve this problem?