Download

Extremely poor performance when testing a blank VR project

Hi,

I am keen to start my VR development journey in UE5 but am having performance issues when I create my own blank project which I need to do to follow the course I am doing.

The example VR project runs smoothly at ~6ms but if I start my own I get ~27ms even though there is nothing in the scene besides the Character class and the floor etc of a blank project.

Are there some hidden settings I need to enable to get it into the same state as the example? I may have to just delete everything in the example project and use that but it would be nice to know how to set up from scratch if possible.

If anyone knows of a good resource for this information or have done this themselves I would greatly appreciate some advice.

thanks,

-Steve

Is Unreal Engine VR dev this dead that nobody has any info in this? o_O

-Steve

Hi, sorry for the slow replies, the AR/VR forum is one of the quieter ones

For starters, check out your project settings. In the ‘rendering’ section there’s a bunch of default settings you can disable, such as bloom, AO, etc. Also find an option to enable ‘Forward Rendering’ which should up the performance by around 35-45%. Then check out your world objects and make sure your sky light and directional light are both set to static and you build lighting.

Then, in-game, you’ve probably got r.screenpercentage at 100 and vr.pixeldensity at 1.0. These values can come down to improve performance at the expense of visual fidelity, so if youre using a Reverb G2, a pixel density of 0.5 will still look fine and halve the number of pixels your PC is trying to render.

These things should put you on the right track :slight_smile: Also check out the Robo Recall performance post-mortem and the UE4 documentation for VR and mobile performance guides.

Another thing to note besides what Bevman stated, is…you might want to do your course with a Stable UE4 version thats not early access. I would recommend at least UE4.25 for VR or even UE4.26…as long as you are not trying to something with water or volumetric clouds, etc. Good luck with your course!!!

UE5 is not VR ready just yet, although it’s not impossible to work with…it’s very new with features that aren’t ready for VR yet. Cheers!!!

The VR Template follows our best practices and doesn’t have features such as Lumen enabled (which is the case in a default blank UE5 project). Since knowing what all of those settings are, the template is meant to exist as a project where you can delete all of the content and not have to worry about the settings - whether you’re familiar with VR in UE or not.

UE5 is VR ready, but Lumen and Nanite aren’t. There’s no reason why you shouldn’t use UE5 instead of UE4 for VR.

Well that’s good news. Thanks for clarifying!!

Now if only the things that are broken for VR in UE4 can actually be fixed in UE5, that would make all of us VR designers feel so much better…that VR hasn’t been forgotten… :thinking: …as VR is definitely gaining momentum in the tech world…

  • Instanced stereo is one of the major ones (it affects water, clouds shaders, just to name a few). Disabling it is a temp fix for some things but that only goes so far, until a project reaches a larger size.

I don’t want to hijack this thread so I’ll stop here, but this list is getting very long for VR issues that seem to just get left behind/unfixed incremental version after version.

Cheers!!! and thanks for listening…

While moving towards OpenXR won’t magically fix unsupported VR features, it will give the XR-team a whole lot of time back since they no longer have to support all of the different VR plugins!

Are there any plans for how long the other plugins will be supported? OpenXR doesn’t seem to be ready for prime-time yet, and the SteamVR plugin at least has so many issues (in recent engine versions at least) it’s practically unusable for production.