Download

Extremely bad performance with 4.14.1 and Oculus

So it’s been awhile since I messed around with unreal and decided to have a look at my project. I updated unreal to the latest first (been months) and my project to 4.14.1. When using VR preview I am getting extremely low framerates (project is simple and ran fine before). They framerate is so low the edges of the screen flicker black while it’s loading frames in.

Thinking maybe the project auto convert changed something I downloaded this VR content examples. In the first area which is just a blank room even with settings all the way down still getting horribly low framerate.

I am running with a GTX 1080 / i7 with Oculus CV1. Anyone have any suggestions?

Sounds like you need to start doing some profiling! First step is to figure out if you’re CPU bound or GPU bound…

Try building lighting and see if that helps, in 4.14 the lighting builds are now separate from the map files so you’ll need to rebulid the lighting if you haven’t already so it can create the new map data files (I may have forgot to do that for the first level)

I’m not sure if anything is a bottleneck. I just recorded a video with a new blank scene (just the chairs and table) and inside the headset running terrible with black flickering when I move my head.
In the video you can actually see the flickering and choppy framerate in the preview window. The frames reported in the mirrored window are some crazy numbers but the ones in the headset with stat fps are around 9.

https://www.youtube.com/watch?v=5ptBjPjxKuU&feature=youtu.be

Tried building lighting does not change anything. It’s not specific to your level a new “blank” level behaves the same way.

So I guess I’m the only one having this issue? I’m not sure where to go from here :frowning:

Sadly, you are not. I am having similar issues in 4.14.1.

What I’ve tried so far:

Stat UNIT reveals very bad GPU performance (> 100ms per frame)
Stat GPU reveals that almost all of this is in HZB, which I believe is related to occlusion culling.

I have upgraded and downgraded my NVidia driver, to no effect.
I have enabled precomputed visibility, added a precomputed visibility volume and rebuilt the lighting, to no effect.

The issue seems to be confined to VR Preview mode for me. Running the game from the VS debugger using -game <mapname> as parameters yields a reasonable frame rate.

Can you please do a GPU capture by pressing CTRL + Shift + ,(Comma Key), expand all the info and then post a screenshot of that. It is really hard to tell what could be causing your issues with the information you have provided so far.

Running Vive and also getting terrible performance with 14.1 but I had everything running flawlessly 90 fps in 14.0

Is this what you were looking for?

I noticed my memory use went through the roof when doing this. Computer locked up the first time trying to capture.
Edit…actually third time capturing memory use was fine. I dunno :).

Yeah. Looks like you’ve got some problems with SlateUI and something in your scene, causing about 100ms between frames, which would put you at about 10fps. Ideally, you’d want to hit about 10.0ms.

So, the GPU capture you posted isn’t very helpful for isolating the exact cause of the problem. But… we can try to ask a few questions to narrow down the scope and nature of the problem.

  1. Do you still get 100ms when you are not using VR preview?
  2. If you create an empty level, do you still get 100ms?
  3. If you switch to another HMD, do you still get 100ms?
  4. If you switch to a blank project in UE 4.14.1, do you still get 100ms?

If you get “yes” to all of these questions, then there may be bigger problems and we’ll have to ask:

  1. Does everyone else in the UE4 community get 100ms with 4.14.1?

It only happens in VR. Even in a completely blank scene with the quality set to the lowest it is the same. In the video it is mainly blank, just the chairs/table that come with a new project. Removing those does not change anything though.

What happens if you disable the realtime preview in your preview window before starting it? (curious :wink:
Also by blank scene do you mean a blank project?

The fact that it is slate using the time makes me think something is going on in your project?

I do not have this issue.
4.14.1 forked from git, this is what it should look like:

3bac6cd922a5c94eee1e142f5614b7d457104500.png

Sorry for the late reply, I was out of town for the Christmas / New Years holiday. Yes, this is what I was talking about and after looking at it the thing that jumps out the most is that Slate is taking almost 53 MS to render and this is what is causing all of the problems as that is extreamlly high for Slate. Did you take this from the Editor or while the game was playing? Also what windows did you have open, Material Editor, Blueprint Editor or something else. It is very weird that Slate is taking up that many resources so tracking that down would be the first thing I looked at.

Oh finally I fixed it! Figured slate could only be from the editor looked up issues with editor and found this:
https://answers.unrealengine.com/questions/270415/editor-lagging.html
Disabled all EVGA tasks and it works fine now. Funny how was only effecting VR.

Thanks for posting back with how you got it working. Someone five years from now is going to see this and it is totally going to help them out.

What is this EVGA thing? I’m having similar issues here. Everything was fine on 4.13, and now I’m stuck at 40 fps on the Vive on the same project on 4.14.

I don’t think you are having the same issue as me. I was getting 9fps on a 1080 GTX. The evga was tasks running for EVGA precisionX. I just removed anything in the task manager starting with EVGA.

I’m just opening a 14.0 project with 14.1 and I’m experiencing the same problem with the Vive. This project also ran flawlessly at 90 fps in 14.0 and now it’s dropping to 45 fps almost all the time. I have a standalone previously built with 14.0 and it still runs flawlessly at 90 fps. Cr1tlord, did you find what the problem is? I’m just upgrading to 14.3 and hoping that it will fix everything.

You might be experiencing this bug: Unreal Engine Issues and Bug Tracker (UE-30406)

Uncheck “interleaved reprojection” in SteamVR and see if you get your performance back. I’ve been in touch with both Valve and Epic about the issue and hopefully it’ll get resolved soon. It happens with UMG widgets as well as SceneCaptureComponents (atleast those are easy to repro)

Thanks Fantasifall, that solved the problem in 14.3… although, even though Stat FPS shows now 90 FPS constantly, I get some hiccups sometimes. I built 14.0 from source and the same project there runs beautifully solid, no hiccups at all. I do not have any UMG widgets in my project but a few video textures that when removed seem to help with the problem in 14.3.