Extreme mouse&kb lag during debugging

I’m having an issue with my mouse and keyboard lagging quite a bit (more than a couple seconds of lag) while debugging (using Visual Studio Pro 2013). I’ve tried the DirectInput emulation settings here Programming Tips and Tools | Microsoft Docs

I’ve tried switching to VS Express 2013. Updated graphics drivers. Everything runs fine normally in the editor, it’s only while I’m in a breakpoint in Visual Studio. The computer returns to normal on resume.
Has anyone else seen this? What’s going on?

I too am seeing the exact same thing. It’s basically making debugging impossible. If you find a solution please post it here! I will too.

Cheers,

Hey yachtrock-

We have not seen any such behavior on our end in terms of debugging. Starting in a fresh project could you list the steps you take that cause this problem to occur?

Cheers

Doug Wilson

I believe the issue was caused by Nvidia drivers enabling ShadowPlay and the GameStreaming system they have. I disabled those and seem to be running fine now. I haven’t tried to turn them back on, so I don’t know for certain yet.

When you get the chance, try turning them back on to see if the problem returns. Also HazeTI- are you able to use the same workaround that yachtrock mentioned?

I’ve verified that disabling ShadowPlay and restarting Ue4 fixes this issue.

I can also confirm that switching ShadowPlay off fixed the issue. Thanks for finding it!

For more info; this only starting happening with the latest Nvidia drivers(version 344.11) as I’ve had ShadowPlay on for months with no issue. I’m running a GeForce GTX 760.

Great. Glad that worked. I couldn’t remember if I’d had it on - but I suppose I did and the new drivers changed something under the debugger.

Can confirm that this fixed it, and that the issue is still present in 344.48 on a GTX 970

GameStream was the culprit, not ShadowPlay here.