Download

Extreme Lightmass artifacts / blocky mess

Hey guys,

I’m really confused, so I baked light in a project and out came this blocky mess, It worked perfectly before but when I started changing the world lightmass settings it just got worse and worse, even with default settings it won’t go back to normal. I even reimported the mesh and replaced it in the level but it still came out like this. Does anyone know why that is? The black mesh in the attatchments is my unlit lightblocker. I’m desperate send help pls.:frowning:

Unlit materials do not cast shadows if i remember right, make it lit but with no specular, also, bake as production and turn lightmass static lighting scale to 0.5 and indirect lighting quality to 4, with indirect lighting smoothness 0.75. See if this helps. That or use it as “intended design”

thank you very much! unlit casts shadows too btw. I did some more tinkering and I found out that the mesh that I use as a lightblocker needs to be closed from the inside too. For some reason that made it work, theres still one little square artifact but now that I know that the geometry was wrong I can fine tune it to make it work. This plagued me for two days and I didn’t even think about considering the lightblocker, thank you Bits360 :slight_smile:

ok so I cranked up the lightmass settings and there it is again, and as before, the more often I bake the more artifacts show up, someone please help, I’m wasting so much time on this now!

Try disabling Lightmap Compression in World settings.
Decrease VLM Detail Cell Size by 50-100, and increase VLM Max Brick Memory to between 40-60. Could also try increasing Spherical Harmonic Smoothing to 0.05-0.1.

What are the skylight and directional light settings? What is the lightmap resolution of the floor with the problem?

Thank you for your help @Bits360 and @presto423, I did some more testing and figured out, that it was the Terrain that messed up my lightmap. As you can see in the screenshots it corrupted the rooms mesh even though it wasn’t even close to the room. The more lightbounces I activated, the more the artifacts reflected onto other walls. After dragging the Terrain further away everything looked normal again. Must be some weird bug with the terrain. Thank you for your help guys! :slight_smile: