Extreme lag when shadow quality is changed from low!

I’m a university student and currently finishing my first unreal task for my course, therefore my knowledge of the software is relatively low so please excuse me if i’m coming across someone as a novice here.
My problem is that I’m coming towards the end of this assignment and need to take screenshots and videos to accompany the actual level.
But upon turning the shadow quality up from ‘low’ (as i have it on at the moment to reduce lag), the whole level becomes impossible to handle, the framerate goes through the floor and sound is jittery and jumpy, making it near impossible to capture footage.

Does anyone have any tips on what i can do to reduce the lag but maintain most of the shadowing on the level as it really encompasses the aesthetics of my creation!
All input is welcomed!

Thanks, jake!

-Which lights do you use in your level? + dynamic or static?
-close as many programs as possible
-check if you run your pc with the “high performance” power settings
-make sure that you use the right gpu (e.g my laptop has two)
-next time I would recommend you to build the level with the “final” quality settings to avoid such issues, because during the level creation process you should also keep the performance in mind :wink: