Download

Exterior Visualization: Foliage (Grass, bushes, ...) + Lighting

Hi!

I’m working on an Architectural scene right now … trying to improve the look of the foliage.
The lighting consists of a Directional Light (Stationary, 20lux, and Cascade Shadow Maps), a Sky Light (Intensity of 1, Captured Scene and Stationary too, because the Cascade Shadow looks a lot better). Additionally there is a HeightFog and Volumetric Clouds, but I don’t assume they contribute a lot to the rendering process. Foliage outside is a mix of grass, bushes and trees out of Forester and some grass-assets are from Megascans library. So there is a little bit of work to do with the materials. The whole foliage itself is Movable, so no light is build for them. (Too high and too complex Lightmaps are the reason, I think? Or am I wrong with this?)

My main problem, beside the poorly material setup for the foliage, are the shadows in the scene. Especially with the bushes that are actually inside the sadow of the trees …
And also the three trees, all the same, are looking different. The one on the left looks like it has some shadow on itself, but the other ones are nearly looking Unlit.
I tried DFAO, but that isn’t working the way I want and also brings up a lot of issues with the whole Interior of the building. Raytracing isn’t an option either, because a VR application is needed.

The question would be, if you, lovely visitor of this thread, look at the images: What could be totally wrong? It is my first real approach on the Exterior and I’m kind of stuck right now. I somehow like the results so far with the grass, but since all the other foliage is placed the whole scene turns bad :confused:

If I missed some important informations about the setup, I’d love to deliver more of it! But for now …!

All the best!

Stationary skylight.

1 Like

Thank you Bits360!

That was indeed a stupid idea. Really don’t know why I thought the Cascade Shadows looked better in the first place. I changed that and also removed the other stuff like fog, clouds or background … just to be sure that these components aren’t influencing anything for now.

Foliage looks better now … but to be honest there is still room for improvement.

Is it even possible to get darker shadow areas inside an already existing shadow, like with the bushes underneath the trees?

If you change the intensity of the skylight it changes the shadow under the bushes as the skylight is an ambient light. What I usually try is to turn either everything off or the intensity down so it is not affecting the scene. Then add each contributor back in to see how it affects the scene.

If your scene is for a visualization and does not have moving lights then you would probably be better of using a HDR image in the skylight and get rid of the direct light. This would light your scene much more naturally.

Another tip would be to use a post process volume for the outside and another for your interiors. This way you can control the exposures and tint the shadows etc.

1 Like

Hi @3dev , thank you for your input.

I already have two post process volumes in the scene, because otherwise the exposure control is going crazy while switching between interior and exterior. But with two of them it’s fine :slight_smile:

I tried to configure each light source separately with disabling all the others and it helps a lot, especially with the subtle lighting. Thanks for that hint.

But for the light setup with only a SkyLight + a HDRI: I tried this within a smaller level, and after some tweaking and googling I got the shadows working. I’m using a static SkyLight, Intensity of 15 for that kind of clear daylight HDRI and with higher Lightmass settings the scene itself looks quite good. But with only one static SkyLight I’m missing the Cascade Shadows from the Direct Light and baking them isn’t an option I guess? Is the only option there to change the Light Channel for the foliage and use an additional Direct Light with Cascade Shadows only on this second channel?

Or am I missing something else?

Not quite sure about the shadows as I don’t use a HDR lighting setup.

I found this page from Epic:

Seems like a HDR specific actor that can do what you want.

Another option is to use the Sky Atmosphere actor for a realistic sky which uses a Direct Light. See below:

So … Thanks again @3dev !

I tried out some stuff you mentioned and got some nice improvement in my overall scene. The HDRI Backdrop is nice, but I came to the conclusion that a Setup with the BP_SunSky actor and a custom Sphere with HDRI background (and the DeriveHDRfromLDR node in the material) gives a better result - at least for now! The BP_SunSky also uses the Sky Atmosphere, which really gives nice results too. The only additional thing was to use the same HDRI (from the Sphere background) also for the, more or less subtle, Sky Light.

From here on I’ve to deal with these dynamic shadows … especially in the distance. The maximum value of 20000 for the Cascaded Shadow Maps are not enough, sadly :frowning:

1 Like

Skylight is not a directionallight

Use far shadows, you can go further than 20,000 but personally i would never go further than 10,000

@Bits360 Thank you for your response!

Regarding this issue: I found out that the dynamic shadow behaves quite strangely and this may even have to do with the way the data was imported. All other shadows in the scene behave normally, only the shadow of the building imported with Datasmith needs a much longer Cascade Shadow Map distance until it becomes visible. Attached are two screenshots of the scene with the distance set to 12000. While all other shadows remain, they are already slowly starting to disappear on the windows.

I really don’t know if I’m missing something regarding Datasmith actors or this is some kind of bug?

[EDIT]

And a few hours later I luckily stumbled upon an explanation for my problem:

Again, far shadows are your friend, they make high res and distance shadows a lot better looking and a lot cheaper (If used correctly), as you can flag certain objects to show up in far shadow, saving loads of frame time.

1 Like

Hi @Bits360 , I tried the ‘Inset Shadows For Movable Objects’ with a higher range than the Dynamic Shadows … in this case I’d expect that the Far Shadow start after the distance of the Dynamic Shadows, but some weird stuff happens again. I lose all the shadows within the grass, which is bad. But the shadows of the trees and in generel get a lot smoother, which would be quite nice if I could control it properly. I’ve found, that using anything lower than Cinematic within the Scalability settings gets me a better result, but not what I want or what I’d expect. Even the FPS drop about 20 if activated.

Are these the right Far Shadows? :smiley:

Yes, but i was assuming you were using movable directionallight, so you dont need it as everything past dynamic is already baked.