Exposed Widgets not showing as a widget class

Please select what you are reporting on:

Unreal Editor for Fortnite

What Type of Bug are you experiencing?



As of v30 I am seeing widgets in Assets.digest.verse, but when I try to access it in my code, it seems to show up as some sort of tuple and not a widget. I tried casting it to a widget and then tried adding it to my UI without doing anything, but neither worked. I also tried accessing elements of the tuple, but that didn’t result in anything either.

Steps to Reproduce

Create a blueprint widget and try accessing its functionality in verse.

Expected Result

The ability to access my bp widgets functionality that would be inherited from the widget class.

Observed Result

The asset in verse is some sort of tuple that can’t be used properly



Additional Notes

This is another thread I started to see if anyone else had solutions but others have confirmed the issue. Pictures are included in my last post Issues v29.30-30 with Exposed Widgets - #13 by TelesphorosGames

Getting the same issue, when trying to access the Widget Blueprint Asset in verse code, it just return tuple of weird types instead and doesn’t seems to be accessible.

Can anyone from Epic confirm that this exposed feature is actually usable and provide some documentation?

1 Like

FORT-756113 incident has been created. Status is ‘Unconfirmed’.