Download

Export metahuman as fbx

Hi,

I’d like to export the torso of my metahuman animation as an fbx sequence so that i can import it into Marvelous Designer and build some clothes onto it for a cinematic. I don’t need the weights etc as i will just be bringing it back in as an alembic sequence. Ideally i would just export the low rex preview mesh.

I’m having real problems finding a way of getting a useable fbx animation which MD will import. Could anyone let me know how to do this or point me to a tutorial?

Thanks in advance

Hi, the way I do it is animate my MH in the sequencer and then right click the body track and bake to animation sequence, in the MH BP change the body skeletal mesh of your MH to the full body preview skeletal mesh so that you have the whole body including the head and then just right click the animation sequence you created and export. In MD just import the FBX and should all work. Alternatively you can bake both the body and face then export them to something like blender and then export them both as one FBX to import in MD. the first option is the easiest and gives you the head also. If you can’t do it I’ll give you some more detail when I’m at my computer. Let me know how you get on?

Hi that’s just the info i wanted, thanks. I hadn’t baked, so that’s definitely one step i need to do. Unfortunately in MD it says ‘file does not contain any mesh nodes’.

I’m still not completely clear about how the BP works, and it’s relationship to the sequencer. Do i have to select the animation in the BP preview before exporting? IE do i need to see the body moving correctly in the preview and then export? Or just swap the skeletal meshes over in the sequencer?For some reason in the BP I select the body mesh with bones (in my case f_tal_unw_body_preview), then when i preview the baked animation (in my case metahuman_base_skel_sequence) and it doesn’t seem to work correctly in the preview… hmmm

I realised in the previous export i had not baked the face, but when i did that i was able to export a mesh. In MD i see the body, head and jeans but sadly no animation and just an A pose. Perhaps that’s because i ticked ‘preview mesh’?

I’ve tried quite a few things now and all i can get is a static A pose out of Unreal with no animation. I have the full body preview mesh working fine as a stand-in for the MH hoodie, I baked the body and face sperately, and it animates how i want it in the sequencer (literally just head moving up and eyes opening so nothing special) but sequencer refuses to export any animation when i export either the body, the face or the whole BP as an fbx

Whole body preview mesh method;
-Create your animation in sequencer.
(Make sure you save)
-In your metahuman blueprint click on the body component on the left hand side.


-On the details pane on the right hand side under mesh select your preview mesh that matches your current mesh, it will be named the same but with preview at the end.

-Then back in sequencer right click the body track and bake animation sequence.
-Chose where to save your animation sequence.
-In the content browser find your animation sequence and right click, go to asset actions and export.
-Make sure you select include preview mesh in the output options box.

-You should now be able to import in to Marvelous designer.

Hope this helps

1 Like

Wowwwwww thank you so much. It worked! For some reason i had not realised i should be exporting from the animation sequence file directly, but from the sequencer. Coming from maya i had assumed that file was just a bunch of keyframes. Thanks a million for taking the time to lay out each stage in the process :slight_smile:

I’m sure this was inevitable (!) but now I can’t seem to get the ■■■■ alembic working back in Unreal!

After importing the jacket from MD, at first it came in completely corrupted ( i believe it was the normql angle setings? or some other setting but not quite sure which one, I finally have it imported and looking correct. But i cannot play it. If i press the game play button the alembic moves but the body stays still. If I press play in the sequencer the body moves but the almebic stays still.

How do I get the alembic file to play in the sequencer so that i can export a cinematic with the clothes running as an alembic cache?

Some more additional info: the alembic plays back fine in maya. I’ve also imported the abc into the sequncer by dragging it accross and adding a track as a geometry cache track. The animation seems to just hang on the first frame.

If you add the alembic to your scene and then to the sequencer, add track to your alembic in the sequencer and add geometry cache, the cache stored in your alembic will be added and now playback in with sequencer, if it doesn’t you may need to add geometry cache component and then add track from there and chose geometry cache component.

Thanks. I can see why it refers to geo cache as ‘experimental’… I’m finding sometimes it works, sometimes not. Following your steps it did work - but when i reopened the sequencer it went back to static again. So doesn’t seem that stable. Currently having to move the mesh around to fit the jacket and fiddle with the frame rates, etc. I’m going to look into doing everything in maya and importing the whole lot as a single alembic now. Perhaps that’s a better way to go?

Yeah just be careful you have the same frame rates for your export from MD that match your original export from the sequencer.
Good luck

I just wanted to say you’re a hero! thank you so much.

2 Likes

Just an update for anyone stumbling upon this. I’ve found a relatively stable workflow - drag alembic into sequencer, add new track to your alembic ‘geometry cache component’ then add a track to the component with ‘geometry cache’. Seems to work. Also I’ve read MD has some issues with 24fps, but dont quote me on this- so i’m currently working at 30fps and having none of the sync issues.

2 Likes

Hi, Is there an easy way to hide the head on the preview mesh? The Preview animation works fine with the alembics, so i am running it just using the preview mesh. That way the clothes do not intersect with the MD alembics.

But i can’t find a way to hide the head on the preview mesh, so that i can use the nice high res metahuman head instead.

The preview mesh seems to have a strange material setup with uv channels outside 0-1 space so you can’t just apply an opacity map to the main material…or at least I couldn’t

Why can’t you just swap your body back to original metahuman body in unreal after you’ve done what you need to in MD?

For some reason the original body intersects with the Alembic clothes and the preview body works perfectly. I have quite a few clothing items and they are super accurate with the preview mesh body but quite a bit off on the metahuman body. Perhaps I’ve done something wrong? Should they be identical?

I wonder if i set the LOD on the preview mesh export too low or something? Or a different LOD to the main mesh.

Either way, I have it working nicely… except for the weird head with a body texture on it!

It would be great if i could just hide the head, but I can’t figure out how the coordinate index/uv channels work on the preview mesh, it seems hidden away in the material instances

Are you sure you’re using the correct body preview that matches you metahuman. In the screen shots you’ll see that I have exported the metahuman body and preview mesh and then imported them in to; blender, Marvelous designer, cinema 4d, and also overlaid them in Unreal. Apart from a small amount of clipping they mostly align. I have looked at the underlying mesh and they also align.




For the body I’ve used f_med_unw_body_preview swapped to f_med_unw_body.

On larger clothes the intersections are tiny but on small items (eg bikini bottoms around the waist etc) it starts to go much further off. They fit fine on the A pose but once the fabric presses into the skin (when the body twists etc) the skin comes through on the original mesh and not on the preview. I’ll try to export as you have done and look at the two meshes together in maya. But the MD stuff definitely fits the preview mesh much better than the original mesh