Export a texture from Unreal Engine?

Hello Guys,

its possible to export a texture out of the unreal engine?

I lost my source texture file.

Cheers,
Heady

Hi!

In Content Browser right mouse button click on needed texture. In menu Asset ActionExport.

Hello svv3dUDN, I have tried this in both 4.7.3 and 4.7.4 and that doesnt work.
I thought I made a bugreport about it for 4.7.3 but cant find it.

It works fine for 1024/1024 textures, 2048/2048 textures, but not 4096/4096 textures. (havent tried 8192/8192)

Edit: 8192 also works. O_o
Edit2: it seems to be a bit more convoluted than I innitially thought.
Will try to find the source of the problem and report in a new post. (unless you are fine with me posting it here)

I imported texture 4096x4096. Delete source file. Save and reload project. Export texture. No problem. Texture exported normally. UE 4.7.4.

I found the issue, it wasnt the filesize but the filetype. 16-bit .PNG doesnt export from ue4. Not only that, but on import the texture is washed out.

UE4 16 Bit PNG Issue - YouTube < showcase of issue.

Edit: updated the bugreport post.

it works with Asset ActionExport, thx.

I think the engine is having quite a bit of issues with 16 bit images Ue4 fail to properly export texture. - Rendering - Unreal Engine Forums

Hey guys, So I discovered a work around of sorts for this issue. When you export the texture, it gives you the warning but it still outputs a TGA file for you. If you open the file in Photoshop (or whatever image editor) you’ll see that it looks wrong. What’s happening (at least in my case) is that it has inverted the color channels. So Green is fine but Red and Blue were flipped. You can fix this easily enough by copy and pasting the channels to their correct spot in a new document. So the Red channel is actually the Blue and the Blue channel is actually the Red.

Here’s a screenshot of my normal map that was exported. The left is how it looked when I opened it up after getting the warning message and the right is after I swapped the Red and Blue channels.

I don’t even have the option “Export” in asset actions! Anyone too?