Exponential height fog too bright

I have a feeling this issue has more to do with me not understanding some basics of UE rather than this being a technical problem. But I can’t get exponential height fog to stop glowing by itself. No matter what color (completely black for example) i set on the fog actor it still emits a light color.

I do understand that a slightly glowing fog probably looks more realistic under normal circumstances. For example producing the look of bright morning mist. But I want to build a spooky dark night scene. Picture something like 1800s London.

I had a directional light in the scene with a very low intensity blue tint. It looks reasonably ok as a moon light so you can just barely make out the details in the scene. The exponential fog actor, however, lights up the scene like a strange glowing backdrop. It makes the scene look cartoonish even.

Not really knowing what I was doing I was guessing the fog somehow scattered the light from my directional light. I turned all and any scattering parameters down to zero but no difference. I even deleted the light source just to make sure it wasn’t scattered light that made the fog glow. But the fog keeps ”glowing” even with no light sources at all in the scene.

Is the exponential height fog always glowing by design or am I just doing something very wrong?

You’re in for a long haul if you’re trying to use fog at night. I found it impossible and just went for a clear night. The fog makes it look like day time :slight_smile:

You might get some joy if you turn off the skylight, but I gave up before I got that far…

Why not just change the fog color to something that works better at night/for the scene?
should still be in the gray range, but darker.

I’m working on a game with fog at night, you just have to make the color dark. And play with the light scattering.

Not that I’m going for ultra realism, but dark fog colors just looks terrible. It looks more like black smoke, and that’s a pretty flattering description. Whatever color you pick is seemingly quite emissive. I think it’s a fair guess that exponential height fog was designed to be used in light scenes. Where the self glowing thingy most likely actually makes it look quite real.

I did experiment with a workaround though. I cranked up the lights in the scene to day light levels, but with a blue tint to it. I then added a post process volume to the entire scene and used a very low exposure setting for the camera instead. It looks much better with the fog. A lot. It actually solved another issue for me. Directional lights, in my case the moon, don’t respond very well to low intensity settings. There’s not much of a visible difference between, for example, 0.1 or 0.6 lux. There’s however a huge difference between 1.0 and 6.0 lux.

I’ve been struggling with fine tuning the light so the scene is barely visible. A spooky scene where you can’t tell what’s around the corners. The exposure setting in post process will let me fine tune the overall light (or dark, more so) very precisely. The fog’s self glow blends nicely into the scene’s now cranked up lighting. And then it’s all exposed down to night time in post process.

You do know you can just create your own post process volume material to power a post process fog right?
All explained here.https://youtube.com/watch?v=N4mkgbwLg7U
That said, the way you went about it makes sense too - just keep in mind that eye adaptation should be disabled, probably with the post process. You probably want to avoid the possibility of it being enabled by console or .ini files…

Coming at this topic with the release of 2.6. Do I understand correctly the exp height fog is not a dynamic actor that I can make react to the sunsky actor/real-time updating skylight?

I’ll answer my own question and in case anyone else has it, this vid:


Then a small question, I am using the fog as well on my level. I have clicked on the Directional Light shouldn’t be rendering. But when I start my level, walk a bit forward and turn 180 degrees(looking behind me) then I notice there is a ball of blinding light. But when I walk towards it, it disappears.
I do use other light sources like lamps and fires on that scene. But the fire source light doesn’t appear when you walk a bit further forward on my level. And I have few lamps around the level so the player will be able to see where the entrences are. So could the light source from the lamps be the cause of the problem? Or is there something else that is causing the problem?

No idea, a reflection capture perhaps?
A bug with the engine version?

Try and replicate it with reproducible steps l and share a video of it…
Hard to tell on just a description…

Here I am showing that I have lowered the brightness of the torch, but as you can see, it somehow makes like a ball of light. But if I do tho turn off Volumetric fog, it won’t be there. But I really want to use the Volumetric Fog. But I think I have at least fixed the problem about why it randomly becomes dark for the camera. So that part is at least fixed.

For the volumetric fog, im not sure.

The torches though need to habe the point light disable at a much shorter range - which will also cure some of the fog issue.

They should really hava a parameter to affect fog…