Excluding objects from being build

I have finished my lightmap uv’s from an object and I quickly want to check with Build if everything is OK.
I’ve hidden all the other objects and I have unchecked “Visible” to rendering. But still everything is building and I’ll have to wait 20 minutes just to check this one object.

What did I miss?

Thank you very much, this solution will save me tons of time.