Download

Exclude foliage from dfao

Hello,

i applied dfao in my sklight since it is set to movable.
Everything works fine except on my plant foliage. My dfao is also just applied to my trees and that one specific plant. I dont know why it is not working for my grass.
I read somewhere that there is a workaround… that i need to set my distance field ambient occlusion of my mesh to 0. I did that but the dfao is still there. I wouldnt mind but it looks really weird.

dfao applied:
[spoiler]

https://image.prntscr.com/image/530d17a5d3eb461088320608783ce6ab.png

[/spoiler]

dfao set to 0:
[spoiler]

https://image.prntscr.com/image/ec9449023f5d49659c41929702976363.png

[/spoiler]

dfao visualisized:
[spoiler]

https://image.prntscr.com/image/2d2b547d0cbf4896a6c709408b4641e7.png

[/spoiler]

I would love toknow how i exclude that foliage from my dfao or why it is not working right and why the dfao is not applied to my grass.

Thanks,

Leon

Someone has an idea ?

how did you “set dfao to 0 on the mesh” ?

also are your plants mesh actors, painted foliage, or landscape grass?

In mesh settings distance field resolution scale:
[spoiler]

https://image.prntscr.com/image/ef0c292f3e254bcab010363ee5f50bbe.png

[/spoiler]

I also changed that value on my other mesh properties to 0 or 1 but it does not change anything.

I just want to exclude that one specific foliage as it turns to black with dfao

  1. set back the DF res.scale to 1 its needed i guess otherwise it will look crappy and low.res,

  2. if u painting instances on landscape using foliage then there is option to use dynamic shadows and cast shadow as 2sided mat set both to true it might work!, you will find it in foliage setting panel.

and btw i still facing the same problems with DFAO/DFGI(the DFGI is removed from 4.16 may be! ) there is a thread i created do join it and spread the word about it. !