Download

Exclude 3D Widgets from Lighting

Good morning everyone. Is it possible to exclude 3D-Widgets from beeing influeneced by lightning? Like a normal Screen-Widget? Because, see yourself:

https://scontent-fra.xx.fbcdn.net/hphotos-xta1/v/t35.0-12/11288565_843047365730404_1154949593_o.jpg?oh=d87b28b3a8771c53e1dc55be5a5a8485&oe=555AF023

The cards get influenced by the light and are way to bright in some angles. Sometimes its really impossible to read anything thats printed on them. I would like to have them one continuous appereance, like billboards (but without the facing the viewer stuff). Thanks :slight_smile:

Edit: And also another question: I wrote a hover function that hovers the card the player has its cursor on, but every time when the hover-ends and the card flips back to its normal position, all the card that where obscured by the hover-display + the hovered card itself are a bit blurry and somewhat transparent for a short time and “fade back in”. The same effect I sometimes see when I spawn objects in the distance: They seem to be faded in. Can I turn this off, because it looks really crappy and most of the time the user has to wait 2-3 seconds until he can read anything.

For the cards, what about setting the material shading model to unlit?

And where would I set that?

In your material, click on the main node, the one where that you plug everything into.
Then on the left, in the details panel, in the “Material” tab there is an option, “Shading Model”, just change it from “Default Lit” (Unless already changed) to “Unlit”.

Which material? Widgets don’t have any material?!

Doh, of course.

Whilst it doesn’t really have a material, you can apply one to it instead of a texture. I wonder if that will do it.