Download

event HIT won't fire in vr

I’m having some issue where my stick will only fire event overlap
but I need it to fire the hit event on my drum.
I do believe my drum and motioncontroller drumstick are setup right but its not firing hit at all.
and the hit event in the drum that is NOT firing.

What is wrong? is this a bug in 4.24?

here is all my collision settings,

stick:

drum:

Hi, looking at you screenshots it all seems to be set up properly. The only thing I’m wondering is if also the drum stick should be set to Collision Enabled (Query and Physics) so to generate hit events.

it says in documentation it only needs to be on 1 of the actors that are colliding for the event HIT to fire. since the drum its self is simulating physics and has the collision needed it is
what should be firing hit. I have tried setting it on both, when set on both the drumstick’s collision capsule collision flies away into space and mother/child relationship is lost.
the collisions are setup properly, yet the event its self in 4.24 is not firing at all.

Did you have any luck figuring this out? I am in a similar situation trying to get a taiko drum to respond to EventHits from sticks. For the time being I am taking the sticks out of the equation and just relying on Eventoverlaps from the players hands.

nope. have not found out why. i did submit a bug report. hope a dev comes here and has a fix for it.

@VictorLerp

Hits are for two primitives that both simulate physics - the collision you’re using on the stick is attached to the motioncontroller, and as such not simulating physics. If it was attached with a physics constraint, the hit event would fire. Try to use OnBeginOverlap instead :slight_smile:

Nevermind i found a work around!

Are you trying to do velocity hit? if you ARE then do as victorlerp said and use EventBeginOverlap.

the overlap event:

then to use the impulse to get the speed I set the volume like this:

Impulse is the speed of the drum stick default = 0

Max Velocity = 700

Max Volume = 4

these seem to be the best settings for the volume of my samples.

​​​​​​​Hope this helps!

Thanks for the help! I’ll give that a try later on today :slight_smile: