"ERROR: The NDK API requested '' not installed in" while indeed installed issue, MacOS M1 Unreal 5

I am trying to set up the VR project on my Macbook M1 with Unreal 5.

After compiling to my Oculus Quest 1, the log said that recommended NDKs are missing. So I installed those through the Android Studio and pointed manually to the directory where they can be found.
I am still getting the same error:

LogPlayLevel: Error:   ERROR: The NDK API requested '' not installed in /Users/me/Library/Android/sdk/ndk/21.1.6352462/meta/platforms.json

this is the directory that I set in the field Location of Android NDK /Users/me/Library/Android/sdk/ndk/21.1.6352462

Would anyone be able to help me with this? I already spent hours on the subject and can’t find the solution. Thanks!

1 Like

same here ):

i think i found the answer if you searched ndk you will see "SDK API level " just delete the box next to it it might have another SDK of the one installed

1 Like

I had same problem with UE5.1, and finally, the issue was resolved after “Project-Setting NDK API Level” was configured

Having the same problem again. UE5.2 with metaXR 1.87//1.88, ndk 25.1.8937393 tried specify/unspecify the ndk&sdk API level, nothing worked. Any other perspectives?

Hi,
you can specify NDK API Level using this labels: “latest”, “android-” (lowest possible for Android’s NDK on UE 5.2 is “android-26” - Android 8.0).

There are information about max and min version you can specify for each ndk version in the platforms.json file.

1 Like