Download

Error "Out of Video Memory try allocating render resource"

I just bought an Unreal Engine Subscription and when I open a project an error saying “Out of Video Memory try to allocate render resource” pops up and closes the project editor? What do I do?

What graphics card do you have? How much RAM do you have?

Well, the problem is I have the worst graphics card so I basically need to buy a desktop or upgrade the card so im going to go for the desktop so I definitely have the storage and the speed.

Howdy Zenidey,

Sorry to hear about your experience so far with UE4. Here is list of what the ‘Recommended Specs’ for running UE4 are: https://docs.unrealengine.com/latest/INT/GettingStarted/RecommendedSpecifications/index.html#recommendedhardware

If you do upgrade your card and are still having issues, be sure to post them on our AnswerHub here: https://answers.unrealengine.com/index.html

Thanks and have a great day!

****, tried to look at one of the free games and my lappy can’t run it. Out of video memory…" error message pops up. Looked up the specs, it only has 2 cores, not quad. ****. :confused:

You can probably get away with having a dual core processor so long as it’s reasonably high end. The out of video memory issues is based on video card, not based on CPU.

i am having this problem as well the graphics card is intel(R) hd graphics family is that enough to run it everything else is fine

How does your Intel HD GPU compare to the minimum or recommended GPU’s?
Or the rest of your system?

See Recommended Hardware.

The Intel HD series will run much slower but can be used if it is new enough.

If you have a HD 3000 most likely you will run into issues running UE4, there have been some improvements recently but in the past this GPU has either not worked at all or ran into major performance issues.

If you have a HD 4000 or higher you should be able to run the editor, but it will be at a fairly low framerate.

To get the most out of UE4 on an Intel HD GU make sure to lower the scalability setting down to low. To do this, from the toolbar click on the “Project & Editor Settings” button, then find “Scalability Settings”. In this panel set each value down to medium or low to increase your FPS.

I was having same problem with my notebook (with itegrated Intel HD 3000 graphics). This morning I try to update graphics driver directly from Intel website (not from notebook manufacturer) and now UE 4.7.6 editor run well. This is the driver source : https://downloadcenter.intel.com/download/23764/Intel-HD-Graphics-Driver-for-Windows-7-8-8-1-64-bit

Hi,

Is there any way to reduce the UE4 editor graphics settings before it opens (e.g. from an ini file?). My laptop can’t quite get there, it gets to 93% on a project load (even a new blank project) and falls over with the out of video memory message (GPU: NVidia GF108 - maybe a bit too much of a push?). I don’t so much need to be able to work on a project, just be able to open it to walk someone through blueprints, editor features etc.

Is there a minimum performance set I can put into the project DefaultEngine.RenderSettings, or maybe an engine ini file that the editor looks at first?

Any help would be great…

If you run out of memory, you run out of memory. Lowering the settings won’t help you there unfortunately.

FYI, there’s no model called the GF108, if it’s getting reported as that, I would check your drivers. You have something like a Geforce 420 / 430 / 440, and they are not suitable for running UE4.

Thanks Ambershee, If you reduce the graphics settings so they don’t need as much memory thought it might help… Ps. GF108 is the GPU chipset in my GeForce430. Anyway no worries, I updated the driver straight from NVidia and it now just about holds on…

Strangely my laptop’s hardware is pretty bad(Intel i3-2350M, double core 2.3 GHz,4GB Memory, Geforce GT 520M, 1GB independent graphics ), but I can still run the UE 4 under Windows 8. However, after resetting my system and installing Windows 7 (Home edition), I got the error message now saying “Out of video memory”. I don’t understand.

In my humble opinion, it is because windows 7 uses “glass theme” by default, have you tried with the “Basic theme” (same theme as in windows 98 one), then restart your computer and try again, and, ofcource, check you video card drivers for update.
Windows 8 does not support “glass” themes, by the way, so thats why why i suggest to try with a basic theme.

Another very usable suggestion for anyone in this thread would be to disable Anti-Aliasing as a global setting for all 3d applications, that you can set inside nVidia Control panel.
To do so:

  1. Right click on desktop and click “nVidia Control Panel” in context menu
  2. open “3D Settings” > “Adjust 3D settings with preview” menu from left side of window
  3. change the setting from “Let application decide” to "Use my preference emphasizing: "
  4. then move the slider to “Performance” (most to the left)
  5. then you can leave it as it is and hit apply, or change option to second variant “Use the advanced 3D image settings” and customize further.
  6. restart your computer.

These steps disable antialing, which affects both Memory usage and performance dramatically, so try this out, if you run out of video memory (it worked on my notebook with 6 GB ram and GeForce 525M videocard, though at the same time i also updated video drivers and enforced nVidia GPU (instead of “automatically decide whether use Intel HD Graphics or nVidia gpu”) from the nVidia control panel "3D Settings > Manage 3D Settings tab.

I got this error message just now. The weird thing is, that everything worked fine for month now. Now all of a sudden I can’t start the Unreal Editor (4.9/4.10), the UT4 Editor (4.8), and when I start Unreal Tournament I get to the point where a map should load and then it crashes. I have a Intel HD Graphics Family card and a Nvidia GeForce GT 525M with Windows 7. Both drivers are up to date.

i have same exact graphics setup as you man, Unreal editor won’t even generate a project, just says no memory to allocate rendering source, :frowning:

Just dropping by to say that I had the same problem with memory allocation, and that downgrading my graphics driver to this version fixed my problem:
https://downloadcenter.intel.com/download/24696/Intel-HD-Graphics-Driver-for-Windows-7-8-8-1-64-bit

I have a T901 laptop with I7-2620M cpu & Intel HD 3000 graphics plus 8 Gb of RAM.
I was unable to even start a project in V4.10 and now on a external monitor I am able to run the sidescrolling templet at ~22FPS at 1280x720 and ~11FPS at 1920x1080.
I havent tried other templets but I’d assume the basic templets have comparable performance (but something like the kite demo I wouldn’t dare to come near :wink:

This is absolutely awesome, it always bugged me that to tinker with UE4, I had to use a whopping 160 Watts per hour from my game pc. Now I can do the same at a fraction of that usage. And the low FPS is really just a minor inconvenience, most of my time is spend in the blueprints, and not in watching the 3d. Although ofcourse this will change further on in development, but by that time I can just switch pcs.

Long story short; got HD3000 + memory allocation problems? Try older Intel drivers.

okay I have this same issue as the OP but I have a graphics card that has 8gb of video memory. I cannot possibly be using that much memory.