Download

Error Lightmap UV Are Overlapping By...

I’ve tried working on three simple projects. Each time I try to import models from 3ds Max I get black irregular shapes on every object. After doing a lot of reading and google searching for a few days I:

  • Tried using “Generate Unique UVs” in the mesh editor. This works on very simple meshes. Does not work for me on anything more complex than a cube.
  • Tried generating a 2nd UV map in 3ds Max and then importing. Selecting the 2nd UV map with lighting coordinate option. This new UV map still gets the same error.

So I’m no figuring out that in order to use most 3ds Max models I’m going to have to make a 2nd UV map and then learn how to manually space out this new UV map so nothing is overlapping. For basically every object… And from what I’m reading this is very time consuming. Isn’t there some kind of better option? This is a big obstacle to completing projects in the engine for people who don’t have a lot of time.

Search for a lightmap generator plugin. Probably you will find something, because in blender I can do that automatically with just some few klicks :slight_smile:

Can you post a screenshot? Perhaps it’s not a problem with your lightmaps.

Same Problem

Hello,

I have the same problem, using Maya

Even if i make just a cube this problem shows up and i haven’t found a way to fix it yet…
This is how it looks in game and in Maya, i also have 2 UV layers with light map but maby i set it up wrong ? or any other ideas ?

ue1.PNG
ue2.png

Looks like you have both a smoothing issue and your lightmap resolution is too small. By default it is 32x32 which is usually too small.

I made it 128 still same problem i also notice an error when importing the model and turn on Smoothing when Exporting top .FBX error disappeared but cube looks the same…

Do you have a lightmass importance volume in your level?