Download

Error: Lightmap UV are overlapping by 40%

… Please adjust content.

Does anyone know how to fix this or even what’s causing it, its becoming very annoying when trying to bake lighting with certain custom objects

You have to:

  1. either create a 2nd uv channel (when you dont have one)
  2. adjust the 2nd uv channel so that the uvs arent overlapping

Which 3d program do you use, because when it’s blender, I can tell you how to fix it :wink:

You need non-overlapping UV’s for your meshes in order to bake the lights properly.

I use 3ds max, i have around 7 custom objects inside my scene but 3 of them are giving me this error, i don’t quite understand what i have to do, is it because i didnt leave enough space inbetween each unwrapped part or something?

When you already have a 2nd uv channel then you have to check if no unwrapped parts are overlapping, otherwise you will have to create a 2nd uv channel first, and then check if the message disappears, because when there isn’t a 2nd uv channel the UE4 uses the normal uv as a lightmap

https://www.youtube.com/watch?v=BY-nKxyHKRc

I’m still really struggling to understand this, iv’e tried making a second uv channel and even spacing out the individual unwrapped parts more, but that does not help, this object has one set of UVs,

Does anyone think this is because i copy and pasted a part of the unwrapped model? its a chester drawers and i only unwrapped one drawer and copied the rest. or is it that im using an outdated fbx exporter, i havent got around to updating mine yet.

That is your problem, it can’t have ANY overlapping uv’s. Just make a second channel and spread the drawers out on it, they need unique uv space to bake properly.

What I want to know is why this wasn’t an issue in UE3, I had dozens of assets that worked fine, now I get this error and they won’t work with lights.

Someone reliable told me it’s because UE3 would default to Vertex Lighting in the case of overlapped UV’s but it’s lesser quality lighting…

To be honest, I’m perfectly happy with lesser quality lighting (my project is meant to be cartoon looking) so other than fixing the UV which takes a ton of time, how can I turn on Vertex Lighting again? Or is that not possible?

**EDIT! - ** Apparently it is not possible to use Vertex lighting, yet…SEE HERE. I understand lightmaps are better, but sometimes it’s not worth the extra work. Hopefully they add it back into the engine, but if not, I understand.

Thank’s for all the replies guys, i’ve never dealt with this before in UDK, what i had to do to solve my problem was to make the drawer unit and the drawer itself as separate objects, this worked out for me in the end as i want to open the drawers anyway.

Yeah, in UE4 you can’t have overlapping UVs for proper lighting

You can either fix this in your modeling program or create new UVs automatically within the mesh properties in UE4, it actually does very good job and ust translate your old UVs to the new UVs so you don’t have to recreate your textures

How do you create a new one? I tried that multiple times with the “Generate Unique UVs” in UE4 and it never worked.

Open the mesh editor and make sure you have the Generate Unique UVs tab open (Window>Generate Unique UV’s)

Now in the Unique UV’s tab check Create New and click Apply

Now in the mesh editor top menu bar click the dropdown that says UV Channel 0 and change it to UV Channel 1 which should be your new UV set, you can enable UV overlay to see the difference between the 2

Save the Mesh and it should keep using the unique UV’s

As you can see here…

I did that, and it still fails. No idea why.

Bring it into 3ds Max and doing the UV there fixes it. But I wonder why it doesn’t work in in Generate UV Script, am I doing something wrong? I do save the file, and the UVs do look different…hmm…

Looks like your UV islands may be too close together.

Check this guide out: http://www.worldofleveldesign.com/categories/udk/udk-lightmaps-01-basics-and-important-principles-for-creating-using-lightmaps.php

What do your normals look like in 3DS?

Also what version of FBX are you using? UE4 only fully supports FBX version 2013 right now

In 3ds max, in the unwrap uvw modifier, change your channel to ‘2’ abandon changes, and just uv it there with no overlaps, its not that hard, and it doesn’t affect your textures.

Possible Solution

Hey guys,

I’ve come across this as well, generating UVs in UE4 worked great for me, as long as I didn’t use the mesh but a Blueprint afterwards, I put up a short video on how I got around the issue, hope it helps someone!

https://youtube.com/watch?v=tgHFppk1dAU

Best Regards
Jona

After you generated the extra set of UVs did you change the Lightmap Coordinate Index to match the new UV set? I ask because I missed changing that. I assume it works when you change in Max and then reimport because the import process automatically sets the 2nd set to be the set to use for the light map.

Go to your second UVW channel > tools > repack UVW’s > done.

I was encountering this problem on my meshes until I found the Light Map Coordinate property inside the UE4 static mesh editor. By default after importing it was set to 0 (aimed at my diffuse UV channel) and had to be set to 1 (aimed at my lightmap UV channel). After changing this I no longer got the lighting build error and the shadows are appearing correctly.

In my workflow I use Blender to create my meshes. Each mesh has 2 UV channels, the first for diffuse texture (where overlap is fine) and the second for lightmap (where overlap is a problem). In Blender you can generate your lightmap UVs via LightPack, if you specify a margin of 1.0 then you will definitely not have any overlap. The key part of the Light Map Coordinate setting is to make sure that UE4 is using the correct UV map.