Download

Error: FMemoryWriter does not support data larger than 2GB

I’m using 4.18.3 version and I get this error when packaging project.
My project folder size is 3Gb.
I saw people compiling bigger projects without problems. I also saw people subdividing the level, but that is not a solution for my project.

I’m sure there must be a solution less drastic than any other.
Any suggest?

Thankyou.

This is my log

And this is my statistic

Did you find a solution to this?

Hi, I had to reduce the lightmaps resolution in many objects. This worked for me.

Can I ask which version of Visual Studio you’re using?

I have Visual Studio 2017 installed, but never used it.

Going by the log, my guess the ‘BuiltData’ file for one of your maps is over 2GB in size - which is too large.

To reduce it, you’ll either need to reduce the size of lightmaps and such for that level - or separate the level into chunks and stream them.

Hmmm… this is quite a heavy limitation for professional visualization projects. We just hit that 2GB limit today… Splitting the environment into smaller chunks and/or finding all objects to reduce lightmap size is a real pain. Why would anyone put a 2 GB limit there? Sounds like some legacy 32bit limitation to me. :frowning: Is there an official statement from Epic on this issue?

I have same Error, It worked for me before i compressed Lightmaps, but that is not the Solution. is there a possibility to avoid this?

@Sharkster-NVR Yep, it’s because UE4’s array class uses 32bit sizing/indexing. I don’t see any obvious reason why they couldn’t upgrade it without breaking serialization from older projects, but perhaps there is something. Probably they just don’t want to touch such core engine code unless absolutely necessary.

This case could also be fixed by just refactoring the cooking code, but I have no idea if it’s something on Epic’s radar.

Guyss…

I had same error. I searched and applied whatever I could find on internet. NO RESULT. Than (I don’t know why) I felt like maybe I shouldn’t use turkish characters in the assets or materials. I searched and changed all the turkish characters to english characters.

And YESSSSSS… It worked for me. It was giving error 1 minute after I start to compile. Now it’s been 20 minutes and still continues without error.

Please try this and share your experience…

TeeHokken,

I’m getting this error (FMemoryWriter does not support data larger than 2GB) on a new project when importing a couple FBXs with simple diffuse 8K textures (eight per geo). My PC has 64 GB RAM and a GTX 1080, have run much heavier projects without this issue. Most of what is said here about this issue is beyond my understanding, and how you had the idea to change Turkish to English characters is even more beyond me. I don’t even know how or why you’d have used Turkish characters to begin with. In any event, is it even thinkable that Turkish characters are lurking in my assets? Is this simply in the name of the file? I can’t see how with this English keyboard I’d have inadvertently introduced Turkish characters, but who knows, have no idea how to move forward. Thanks.

Hi,

I’m hoping this will help others.

I had the same error when trying to cook the content, I have 4 lighting scenarios in my archviz project and they were all above 3.6GB!

The problem for was not the lightmaps being too large or too many it was actually the reflection spheres. I had over 20 of them and I had the resolution for sphere capture set at 1024. After erasing most of them and changing their resolution to 512 all my lighting scenarios went from 3.6GB to just 0.8GB!! well under the 2GB limit.

So whoever encounters this problem please check your options for sphere capture and see if you can remove some from your scene, this will help greatly! It’s a quick fix as well, you don’t have to bake anything just remove what you can and then press SAVE ALL and check the new size of the BuiltData in your content folder.

Regards

Your answer didn’t work for me, but it did point me in the right direction.
Removing the reflection captures alone didn’t work. I did this and I also changed my static lighting level scale (under world settings) to 1 (from 0.2). Of course I had to build again after this.

Well I’m not sure if can call this a “solution”! :S That’s a HUGE visual difference!!!

I have the same issue, but all that is said here ain’t working for me.

Only have 2 reflection probes, checked every name, my lightmap for every model is 64 (was 512), changed my world settings to default, my builddata is below 600mb, tried a new project. All this without any success.

So what is causing this problem…

Solved checking Compress Lightmaps. I always bake LM with compress unchecked, It’s a fact I don’t like to compress because the artifacts but also it is true unchecked multiply by 4x memory a disk usage.

Too much dirt/artifact with compressed lightmaps!! :S
…the only solution I found is to split up the interior into separate streaming levels…

so it is big with builddata,because lightmap is big,so …it is dirty