Error: Failed to build UnrealBuildTool in Manjaro (Unreal Engine 5.0.2)

Hi, I am new to Unreal in Linux and still new to Linux in technical things.
I am on Linux Manjaro, Gnome 42.2

During executing ‘GenerateProjectFiles.sh’ getting these errors

Attempting to set up UE pretty printers for gdb (existing UEPrinters.py, if any, will be overwritten)...
	updated UEPrinters.py
	found necessary entries in ~/.gdbinit file, not changing it.

Setting up Unreal Engine 5 project files...

Setting up bundled DotNet SDK
/home/zaqraven/UnrealEngine-5.0.2-release/Engine/Binaries/ThirdParty/DotNet/Linux/sdk/3.1.401/NuGet.targets(255,5): error : Unable to load the service index for source https://api.nuget.org/v3/index.json. [/home/zaqraven/UnrealEngine-5.0.2-release/Engine/Source/Programs/UnrealBuildTool/UnrealBuildTool.csproj]
/home/zaqraven/UnrealEngine-5.0.2-release/Engine/Binaries/ThirdParty/DotNet/Linux/sdk/3.1.401/NuGet.targets(255,5): error :   The SSL connection could not be established, see inner exception. [/home/zaqraven/UnrealEngine-5.0.2-release/Engine/Source/Programs/UnrealBuildTool/UnrealBuildTool.csproj]
/home/zaqraven/UnrealEngine-5.0.2-release/Engine/Binaries/ThirdParty/DotNet/Linux/sdk/3.1.401/NuGet.targets(255,5): error :   The remote certificate is invalid according to the validation procedure. [/home/zaqraven/UnrealEngine-5.0.2-release/Engine/Source/Programs/UnrealBuildTool/UnrealBuildTool.csproj]
GenerateProjectFiles ERROR: Failed to build UnrealBuildTool

How to fix this? Also, I need a specific like where the code should be put to.

1 Like

hi
UPDATE to @ZAQraven99
Follow the answer in the post about setting up SSL
Error: Failed to build UnrealBuildTool in Manjaro (Unreal Engine 5.0.2) - #post 10

Then maybe use the link below

You may need to load the new toolchain describe in the
Linux Developers
Linux Development Requirements for Unreal Engine | Unreal Engine 5.0 Documentation

Hi ZAQraven99, same issues here. Did u find a solution?
I forced clang-13.0.1 … but i got the same errror.

Sorry for my late reply.

Sorry, I think you don’t understand carefully. As described

Unreal Engine’s setup shell script (Setup.sh) automatically downloads a native toolchain, which guarantees your compiler and linker to work with our codebase.

Hi, no luck. Only work on Ubuntu.

Also broken for me on Gentoo:

DOTNET_SYSTEM_GLOBALIZATION_INVARIANT=1 ./GenerateProjectFiles.sh
Unable to load the service index for source https://api.nuget.org
/v3/index.json
The SSL connection could not be established, see inner exceptio
n.
The remote certificate is invalid according to the validation p
rocedure.

No idea where the problem is because I can wget that address just fine

Fedora 35 here, same error.

Maybe in the future then.

Same for me Fedora 36 :frowning:

it seems branch origin/ue5-release-engine-staging is working for me, so far. no idea which version that is exactly but I saw it received updates recently and switched to that one, while release seems to be stale

Try running this before ./GenerateProjectFiles.sh

export SSL_CERT_FILE=/etc/ssl/certs/ca-certificates.crt
export SSL_CERT_DIR=/dev/null

It should work again.

5 Likes

thanks. worked for me

Hi, I have the same issue but the suggested fix isn’t doing anything for me. It still comes up with the same error msg.

λ sudo ./GenerateProjectFiles.sh
Attempting to set up UE pretty printers for gdb (existing UEPrinters.py, if any, will be overwritten)...
updated UEPrinters.py
found necessary entries in ~/.gdbinit file, not changing it.

Setting up Unreal Engine 5 project files...

Setting up bundled DotNet SDK
Process terminated. Couldn't find a valid ICU package installed on the system. Set the configuration flag System.Globalization.Invariant to true if you want to run with no globalization support.
at System.Environment.FailFast(System.String)
at System.Globalization.GlobalizationMode.GetGlobalizationInvariantMode()
at System.Globalization.GlobalizationMode..cctor()
at System.Globalization.CultureData.CreateCultureWithInvariantData()
at System.Globalization.CultureData.get_Invariant()
at System.Globalization.CultureInfo..cctor()
at System.String.ToLowerInvariant()
at Microsoft.DotNet.PlatformAbstractions.RuntimeEnvironment.GetArch()
at Microsoft.DotNet.PlatformAbstractions.RuntimeEnvironment..cctor()
at Microsoft.DotNet.PlatformAbstractions.RuntimeEnvironment.GetRuntimeIdentifier()
at Microsoft.DotNet.Cli.MulticoreJitProfilePathCalculator.CalculateProfileRootPath()
at Microsoft.DotNet.Cli.MulticoreJitActivator.StartCliProfileOptimization()
at Microsoft.DotNet.Cli.MulticoreJitActivator.TryActivateMulticoreJit()
at Microsoft.DotNet.Cli.Program.Main(System.String[])
./GenerateProjectFiles.sh: line 31: 68385 Aborted                 (core dumped) dotnet msbuild /restore /target:build /property:Configuration=Development /nologo $BASE_PATH/../../../Source/Programs/UnrealBuildTool/UnrealBuildTool.csproj /verbosity:quiet
GenerateProjectFiles ERROR: Failed to build UnrealBuildTool

The variable I set got me past that error, or a similar one, I think. If that doesn’t work then I don’t know, this thing is buggy as hell

thanks a lot !!

I think I did it!

In Fedora just execute the steps manually (from here ./GenerateProjectFiles.sh) and a Makefile will be generated. (after executing Setup.sh)

It’s actually just a dotnet restore/build and a dotnet command to execute a DLL, not biggie.

I’m building it right now. I’m posting before finishing the build to jinx it. :stuck_out_tongue_closed_eyes:

I don’t get it, I don’t understand your fix at all, has someone had any luck with this issue on Arch Linux? Unreal devs released official version of UE5 for Debian based operating system so it is a bit dissapointing

were you able to build in the end?
running Setup.sh does not generate make file for me.
Running GenerateProjectFiles line by line only led me to the same error when I tried to run:

dotnet msbuild /restore /target:build /property:Configuration=Development /nologo $BASE_PATH/…/…/…/Source/Programs/UnrealBuildTool/UnrealBuildTool.csproj /verbosity:quiet

Still get the error on Rocky linux. even after the env vars setup

For the others who posted still having issues. The two vars i posted above are in relation to this error:

The SSL connection could not be established, see inner exception

The other error i read above:

Process terminated. Couldn’t find a valid ICU package installed on the system. Set the configuration flag System.Globalization.Invariant to true if you want to run with no globalization support.

is not related to OP’s issue. Don’t know about the others if it’s also related. But maiby output your error just to be sure. Also sorry for late reply. I’m not on the forum a lot.

But just as a general tip. Try to find the exact issue inside your error message and look that up. That’s actually how i found the fix I posted.

I’m using it right now.

You may need to adapt the commands, like modifying $BASE_PATH to the correct path pointing to .csproj.

You just need to build the project, then CMake will do the rest when you tell it to make.