Error: Default Scene Root is not static

Hey Guys.

I made a script that creates Houses. Now i get this Warning… Anybody an idea how i can fix this ?

" default scene root is not static…cannot attach mesh component which is static to it "

2 Likes

Ahh. Found it. Had to change from movable to static in the “Components View” under “Class: Default Scene Root” in the Blueprint…

7 Likes

Your find saved me a big headache… 9 years later !

3 Likes

OMG thank you, this answer saves me in 2022 as well!

2 Likes

same :3

2 Likes

This has now saved 3 people in 2022 XD

1 Like

This has now saved 4 people in 2022 XD

1 Like

Make that 5 in 2022! Thanks for sharing this!!! For those curious as to exactly where to do this, hopefully this will help. Cheers!

Make that 6~. thank you.

I get the same error during Builds, but default scene root is STATIC. I triple-checked, reclicked the settings to refresh them, etc…
I have a setup with a parent blueprint, and a lot of children blueprints. And, for some unknown reason, SOME of the children get this error. Everthing is set to static. Unreal, PLEASE!

There’s an unfixed bug in Unreal(big whoop). Go through each static item in your scene and switch them from static → to movable → to static again. This should fix it.

2 Likes

My solution was to set the entire SharedRoot to Static, and all child meshes to static for AttachTo.
If you have a mesh inside like a door that needs to be Movable, but still needs to be AttachTo and be static, keep it set to static. In the Event Graph, on EventBeginPlay → Set Mobility to Movable.

WOW! This problem has haunted me for so many years, I can’t believe it was that easy to solve. No one else I’ve talked to has had that problem yet I have it all the time

Even better solution I recently found:
In your parent’s constructor, loop through all it’s child actors, and set their root component’s mobility to static and immediately back to movable.

This way you never have to fix it manually again.