ERR-017: DK2 looses connection

I seem to be having some issues with UE4, as this problem only happens when using the editor (and previews), it happens often enough to where it is extremely annoying though.

When I am in the editor, I get a message from the device manager / action center stating that the headset has been disconnected, and then it reconnects. There is nothing in the Rift diagnostic logs (See below for Server log) nor is there anything in the UE4 logs (since it did not crash).

However, in the system event logs, it shows 9 errors, of 2 different types (the headset disconnected and reconnected one cycle). All of the errors are:

Error: {ERR-017} [HMD] WARNING: LED state change unverified!
Error: [From Service] Date/Time stamp: {ERR-017} [HMD] WARNING: LED state change unverified!

The Oculus server logs shows that when the service looses sufficient IMU samples, it will drop the connection to the Rift and then reconnect it. However, this only happens in the UE4 editor, not in the Oculus demo scene or other games/demos.

Hello SaviorNT,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed set of steps to reproduce this issue on our end?
  3. What version of the oculus runtime are you using?
  4. Could you provide your dxdiag?

Hi Rudy, to answer your questions:

  • This happens intermittently, and it happens with clean projects using both the RiftFirstPerson template as well as the new 3rd person template from epic
  • I have no idea how to reproduce the issue, yesterday it happened right when I launched a clean project, today, I launched yet another clean project and it hasn’t occurred. Other times it will happen several times in a row. Nothing that is in the background is different from yesterday and today
  • Using the current runtime, 7.0 and UE 4.9.1

DxDiag Report
Oculus Server Report
Event Viewer Logs

Hello SaviorNT,

After looking over the new information, I have a few more questions for you.

Additional questions:

  1. Could you try plugging the cord on your oculus with the USB into another port?
  2. Have you tried shutting your computer down all the way (not restarting) since installing the latest runtime?
  3. Do you have access to another computer in which you could test this issue on?

Good morning,

  1. I’ve tried 3 different onboard USB hubs and a powered USB hub.
  2. I haven’t done a complete shutdown of my machine for a few years now, I suppose I could try that today when I’m at work.
  3. No other computer with sufficient specs to run UE4 or the Rift.

Hello SaviorNT,

Did you have a chance to try shutting down your computer to see if this would help?

Hello SaviorNT,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.

Hi Rudy,

I’ve been using UE4 for the last few days when I have the chance, and the headset has not been disconnected.

Hello SaviorNT,

I am happy to hear that your issue has been resolved. If the issue returns please feel free to reopen this thread. For now however, I am going to mark my last suggestion as the answer. Thank you for your time and information.

Make it a great day