EQS Deprecated. Can't package game

Hello. I’m trying to package my project but I’m getting this error message that I do not understand.

“LogAIGraph:Error: DEPRECATED: This class is now deprecated, please use RunMode supporting random results instead.”

I figured out it must have something to do with the EQS system as I have found the word deprecated in the run EQS task in the behavior tree. What am I missing here? I set the run mode to the random ones but no change. Also, I cannot changed the upper run mode that says deprecated. I’m guessing that’s normal.

Any ideas?

Hi measuring,

What version of the engine did you convert from? For example did you jump form 4.13 to 4.14. Also would you be fine with uploading a small sample project that has a behavior tree that replicates this issue. (please inlclude any other necessary assets needed for the error).

The DEPRECATED class in that message wasn’t mentioned in the release notes so that may need to be addressed.

Also, another good test would be to make a similar setup in a blank project. If the deprecated warning doesn’t appear then this may be a conversion issue that needs looking into. It would be much easier to determine this if you provide a sample project though.

Thanks,

Hey Ed.

The project has been converted to every major version since probably 4.3 haha. This error did however appear right after going to 4.14. How would I go about looking in to conversion issues?

I tried creating the same behavior tree in an empty 4.14 project and I still had the Deprecated parameters in the editor but it did compile successfully.
I unfortunately won’t be able provide a sample project.

That’s fine. If a sample isn’t possible could you take a screenshot of your behavior tree (or at least the relevant parts of it) so that I may be able to assist you with your issue.

Here’s a picture of the behavior tree with the EQS node selected. Screenshot - 4332c0e849cd7abd51377e27f42bca23 - Gyazo

If you would be able to help me out over skype, I could show you the tree more in depth and hopefully find the issue. My skype name is edvin96wenden if you’d be up for that. Thanks!

Any updates? Got stuck into the same issue at 4.14.1

Nothing yet unfortunately. Did this issue happen to you after 4.14 as well? Because mine worked fine in previous versions.

Hi measuring,

We have made a few changes to EQS query regarding the way the details panel is setup. Look at the screenshot and make the appropriate changes and let me know if this addresses your issue.

If not please leave a comment and I will continue my investigation.

Cheers,

Ed

Hey!
I tried to create a new EQS node and only changed the bottom settings (the new ones) but the issue remains. I’ve tried setting runmode to one of the random settings but that doesn’t change anything either. I keep getting the same error message when packaging the game. Any kind of logs that I can provide you with?

Thanks.

That may be a bug, I’ll investigate and update you with a JIRA if necessary.

That fixed issue in my case in new project, thanks.

Hi Measuring,

Try this, recreate your Behavior Tree in a new project and see if it works like Voradori. If it does you may just have to recreate all of your behavior trees using the new settings and don’t even touch the DEPRECATED ones.

If you still get errors packaging please provide your full output log (preferably in a .txt file attached - you may have to zip it).

I did try doing that yesterday and indeed it is now working so it must’ve been a conversion issue.

Just note that I never did touch the DEPRECATED options even when recreating the tree in the version of the project that wasn’t packaging.

Hi measuring,

I did a bit of testing and couldn’t get the DEPRECATED error to occur. Could you provide a small sample project that gets this error when you convert it to 4.14?