Download

Epic's GPUlightmass

Seconded on point #2

This alone would increase productivity and help scheduling massively.

We’ve just implemented Intel Open Image Denoise for lightmap GI denoising in Dev-Rendering. Denoising in preview is not supported as the latency is very high. However you should be able to get way less noise in baked lightmaps. Still, to get good quality with this brute force renderer you’ll need very high sample counts (16k). The denoiser may be able to reduce that to 512 - 1k though.

Is it possible to add support for the Two-sided foliage model in lightmass? eg. light scattering through leaves to the area below.
Would be really nice for forest environments

Probably EPIC knows but just in case. Change log for March 17, 2020 Vulkan 1.2.135 spec update: · KhronosGroup/Vulkan-Docs@18caa8e · GitHub

Nice! With 1k settings for both sample counts the same project as before (page 1, 4th post) now results in this image. A big visual improvement.

compiling… Just realease the kraken :smiley:

another test without denoiser
https://youtube.com/watch?v=u1c2TonsAzE](https://www.youtube.com/watch?v=u1c2TonsAzE)

This is so awesome. Cant wait until its in an actual build ready to use :slight_smile:

Does it handle hlods well? Luoshuangs old one used to not handle those and take the hlods into account into lighting the rest of the envrionment leaving awkward lighting where hlods would intersect.

HLOD and LODs are not implemented currently, but shouldn’t be very hard on top of the new system (with proper instance management)

https://youtube.com/watch?v=B6fr6DJEvw8
my try in sample 8k…still some noise, any suggestion? do i need re compile dev render again?

@tc22 some things I would try to improve quality;

  • use 3d geometry you modeled yourself with proper lightmaps in 3dsMax/Maya/Blender
  • using higher lightmap sizes
  • disabling lightmapp compression in the world settings

Thank you Maxbrown!

i rebuild devrendering again , it seem less noise in viewport!
and add denoise gi option! see attachment!

seem in shadow there still had movement noise , i don’t know why it happen !

Note that when you enable ray tracing, realtime ray traced shadows will be on automatically. You probably want to set r.RayTracing.ForceAllRayTracingEffects=0 to disable all realtime ray tracing effects.

great work Luoshuang (and the rest of the team), really looking forward to this once it’s released

also it’s great that you’re reacting to feedback on this thread. so a couple of questions from me:

  1. will this work on non-RTX cards?
  2. any chance the whole thing could work at runtime? thinking of a scenario like building a procedural level and then building static lights, all under a loading screen

@Luoshuang
shader compiler is incredibly slow. :smiley: is it normal or just for me? also visual studio compile takes 3.5 hour(other branchs max takes 1 hour) lol :smiley: thats need patience work definitely.

rests incredible. denoiser working good. thx for you and your team works.

i will share the results of denoiser with single material.

https://youtube.com/watch?v=uXYNAtux_94

I beg for help! I have been trying to build ue4 dev-render for a month now. I just can’t solve this problem - the engine has assembled with errors and does not start. can someone know how to solve this? I will be very grateful for any help!

[/SPOILER]

Yes, I also faced the same problem in VS2017, decided to use VS2019 (no errors, no warning)

@Luoshuang It’s just a small thing but you could rename “ToggleLightMapPreview” to “r.GPULightmass.ToggleLightMapPreview”. Would be nice to have all the relevant commands in one place.

Well that’s because ToggleLightmapPreview belongs to FStaticLightingSystemInterface - an interface allowing ppl to implement their own lightmap baking system beyond GPULightmass

I see. Thanks for clarifying!

Hi,
ineed help.
I played last week with dev-rendering build and gpulightmass, worked fine. Now I downloaded the latest one, and it is not working anymore. By “ToggleLightmapPreview” Command I got this error:

gpulmerror.jpg

Sorry for my bad Englich :slight_smile:

Thanks