Epic Games launcher frustration extreme

Is there a way to prevent the Epic Games launcher from loading all the time? I don’t need it for the most part, I load projects double clicking on the project file. But somehow, it always loads back up, no matter how many times I close it. It’s became really annoying, because it’s something taking up memory when I don’t need it for anything, except when I have to install a new version. This is for both Mac and PC.

What do you mean by “all the time”? Every time you click the mouse? Every key you press on your keyboard?
If you’re asking how to prevent the Launcher from loading when you start your computer, go in to the Launcher settings and clear the “Run When My Computer Starts” check box.
To be able to close the launcher, clear the “Minimize To System Tray” check box.

1 Like

“All the time” is a manner of speaking. I mean that, if I launch the editor from the project file in the Finder, the project loads, and shortly after, the launcher loads behind. If I close it, eventually it opens again by itself. And if it’s closed and I quit the editor, it launches up again. It’s like a needy teenager saying “Look at me, I’m here, I have so much great stuff to show you!” :smiley:

And yes, there are a lot of times where I want to use the launcher, I just don’t want it opening in the background. It’s definitely not set to open at system boot, or run in the background, I have everything uncheked in the settings.

I dont know in Mac, but in windows doesnt happens to me.

By default Epic launcher installs and runs on your computer startup…you can disable it by pressing windows key and typing startup…there will see the list of apps that runs when you turn the computer on…you can just disable the epic launcher…

image

also if the epic launcher is in the tray you can just close it and it should not bother again.
image

I know, in Windows it’s not so obtrusive, it goes in the tray until you need it. In macOS it keeps launching and launching. And no, I don’t want it in the macOS tray area either because you can’t choose which icons to show like in Windows, they’re all there always, and I already have too many.

Hi @sebalv70!

I believe if you open your settings menu in the Epic launcher (found on the bottom left corner) there are options like “Run in background” and “Run when my computer starts”. Deselecting these options may prevent the launcher from automatically opening.

Here is more context via a great forum post:

How do I stop epic games launcher from running on start up on Mac OS?

I hope the above solution works for you!

Thanks Quetzalcodename, but all those settings are deselected, and still the launcher opens very often in the way I described above.