Epic games launcher error when installing

Hi TeoK,

You should be able to upload your logs directly without zipping them now. The ‘No such upload’ error sometimes happens when we are experiencing large amounts of traffic. Generally if you keep trying it will upload.

Here is some troubleshooting steps to try. Look in the ‘Unable to Install the Launcher’ section first.

Hello, when I try to install the Epic games launcher it stops when installing Directx, the error says: “There is a problem with this windows installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.”
And it is on C drive.
I have the Log file, but when I try to upload here in a zip or rar, it says: “No such upload”

Thanks.

here is the Log

Sorry, but can I get an answer please. I dont know what to do

I am having the same problem here… Please help. x.x

Have you guys made sure you’re on the latest directX?

-Max B.

Also this may be a similar issue to this one: Epic Games Launcher installation hangs at DirectX installation, then closes (similar to question 181231) - Getting Started - Unreal Engine Forums

Try the solutions they mention there in the answer section and see if that fixes your problem.

Tried it… Still not working… x.x

in your command line type

msiexec /i “the_location_of_your_msi_installer.msi” SKIP_DIRECTX="1"

you might find it easier to navigate first in command line to the location of your Downloads folder, or wherever the msi was downloaded

also can someone confirm if this is a windows only issue or are mac/linux users affected.

Was having the same problem till I ran as administrator and made sure I had enough space on the C drive.

I looked through your logs and it’s showing the error code -9. Look at this thread’s accepted answer on how to fix the DirectX -9 error: https://answers.unrealengine.com/questions/60779/ue4-launcher-cant-install-fail-at-directx-install.html

I can confirm, Im also affected, got same error, read more info here

Okay i found a solution to this issue. It seems like the installer when trying to install direct x files it stalls and crashes. The cause for this issue was both files located in sysWin32 and sysWOW64 known as d3d9.dll. Download Take Owner Ship from google and add it your registry. Afterwards, proceed to syswin32 and sysWow64 and right click - take owner ship and then rename d3d9.dll to d3d9.dll.old. Once they are both renamed, download DirectX End-User Runtime Web Installer ( Download DirectX End-User Runtime Web Installer from Official Microsoft Download Center ) Run as admin - install the files - restart - install the epic launcher again.

Hi TeoK, Reiner, & Vido05,

Could you all verify that you have tried all of the solution listed in this thread so far and post if the issue is still happening for you?

I didn tried what colt0 suggested, but I can confirm that wehn I placed d3dcompiler_43.dll (x64ver) in EpicGamesLauncher on my win7x64 fixed issue :slight_smile: Tnx

Hi, it worked for me, I followed the instructions from the Maximusdb3s links. Thanks.

Was having the “There is a problem with this windows installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.” error, and what I did to fix it was download the Visual C++ Redistributable at Download Visual C++ Redistributable Packages for Visual Studio 2013 from Official Microsoft Download Center

At first I only downloaded the x64 version (as I am on a 64 bit machine) but it still was showing the same error message. So after I tried downloading the x86 version too and it worked.

yo lo solucione de otra forma solo instale normal hasta q salta ese cuadro con el error no hice nada mas bien hice doble click en el icono del epic launcher que estaba en el escritorio y cuando salio el cuadro negro del epic launcher acepte el error del otro recuadro y instalo el launcher normal