Epic Game Launcher crash

I’ve used the Unreal Engine 4 for a couple of weeks without problems. When closing the software a week or so ago, the launcher updated itself. After this the launcher crashed upon opening.

What I have found is that the software crashes when I go to the Unreal Engine 4 tab of the launcher. And when the program has crashed once, the software crashes between the login screen and the launcher screen. If I delete the appData/Local/EpicGamesLauncher/ folder it resets the error. Thus I can again see the launcher, but the entire thing freezes and crashes when I navigate to the Unreal Engine 4 tab.

The specific error I get is “EpicGamesLauncher has stopped working”.

I’ve gone through all tips I’ve managed to dig up on the matter - reinstalling the entire launcher, trying the “-http=wininet” and the " -OpenGL", updating the redist DirectX, updating all windows files and drivers, Visual Studio C++ 2013, and so on. I’ve tried doing the different steps in safe mode too just in case. When trying Dependency Walker it suggest I am missing 8 DLL’s:

API-MS-WIN-CORE-KERNEL32-PRIVATE-L1-1-1.DLL

API-MS-WIN-CORE-PRIVATEPROFILE-L1-1-1.DLL

API-MS-WIN-SERVICE-PRIVATE-L1-1-1.DLL

API-MS-WIN-CORE-SHUTDOWN-L1-1-1.DLL

EXT-MS-WIN-NTUSER-UICONTEXT-EXT-L1-1-0.DLL

ICUIN53.DLL

ICUUC53.DLL

IESHIMS.DLL

Now I don’t know what more to try. Any help would be greatly appreciated!

Logfiles

DxDiag

I’ve encountered the same error. I just installed Epic Games Launcher yesterday. I’ve ran the troubleshot and it said the error was that the launcher was incompatible. I haven’t figured anything out to fix it yet.

Same boat, I had to reformat my computer… now that I am reinstalling UE… crashes the moment it opens the launcher. Uploaded log, and much like the person who started this thread… I tried all the same things… nothing workedlink text

I really don’t understand what the hell is happening. I had the same error with both UE and Unity. I don’t know if reinstalling the OS should work but I really don’t want to try that way.

Hi all,

I’m sorry to hear that you are experiencing this issue with the Launcher, and I apologize for the delay in response. This issue is under investigation by our engineers and we will follow-up with information or additional questions.

Brother Eye, can you please provide your Launcher debug logs as well? Information on how is available here.

Thanks

Hey all,

We apologize for the inconvenience, and we are still investigating this issue. For those that have been affected, could you do the following to enable more descriptive logs?

Right click the Epic Games Launcher shortcut on the desktop, and select properties. In the target line of the shortcut tab, after the installation path of the launcher in parenthesis, add the following commmands: “-forcelogflush” “-debuglogging” (without quotes).

Once you have done so, if you are able to reproduce the crash and post those new logs here, that should give us more information to investigate fully. Thanks for your patience.

Quick question, are you using any specific antivirus or VPN software? If so, what are they?

Also, could you check to make sure you are not behind a proxy and do not have epicgames.com filtered? You can check to see if you are behind a proxy here. If you are behind a proxy, add an exception for epicgames.com (or ask your IT department to do so).

added new files. the updated log, and a picture of the properties with the added text in the target field so you can make sure I added them correctly to the existing target. let me know if there’s any issueslink text

also I am not using a proxy and I am using avast antivirus but there is an exception for Epic Games Launcher

Heads up that we are re-directing all of the recent reports of the Launcher crash to this post in order to focus our support efforts and consolidate information. Below is the list of other duplicate reports about this issue which may contain useful information for Epic’s investigation:

Thank you for taking this matter seriously. I’ve added the new parameters to the shortcut, and now the launcher actually did download an update. Sadly it does still crash. I am not behind a proxy. I use Kaspersky antivirus software and Ad-Aware anti-spyware.

Here are the new logs:

New Logs

I had Unreal installed before my anti-virus ><… was crashing before and after the installation of AVG, and Malwarebytes

I thought I was the only one to have this problem. I opened up the debugger and it is saying that UE is trying to access information that is not allowed

I was able to reproduce this problem with - Ad-Aware anti-spyware. I also noted that after simply removing the Ad-Ware application that the problem remained. It appears that LavaSoft also installs a secondary application called 'Web Companion". After uninstalling Web Companion (from Lavasoft) I was able to launch the UE tab with out any problems.

I assure you we’re still looking into all of these cases and doing our best to find the underlying problems. Let us know if this solved the issue for anyone using LavaSoft software; we’ll continue investigating other software as well.

Thanks!

Removed it, no change… still crashes. Latest Logs

Removing the web companion worked. Yaaaay!

Thank you for finding a fix!

We’ve identified a problem with some Adware providers where they are blocking some portions of the Unreal Launcher on the Community page. Namely, I’ve seen this with the LavaSoft program ‘Web Companion’; unfortunately turning off Web Companion doesn’t seem to fix the problem and it had to be uninstalled.

We’re in the process of trying to fix the root problem and ensure that these programs are not blocking any of the functionality that the launcher needs to operate. In the meantime, removing the suspected Adware/Malware program should do the trick if you’re seeing ‘Crashing/Hangs’ when entering the UE page.

Thanks for your patience as we try and resolve any issues with this.

Same here! Thanks for the fix :slight_smile:

Mr. White,
you sir, are amazing. I cannot thank you enough.

TheMatrix

You are the King of the World.I think you kinda saved my life with this.Thank you, it works! :slight_smile: