Enhanced Input blueprint event nodes disappear on engine reload

I’ve been playing with the new enhanced input system in UE 5.3. Attached to my character blueprint I have some Input Action event nodes for sprinting and pausing.


When I save my project and reload, this event node has been removed. Any ideas here? I’m not too sure what to make of this, the sprint / pause actions work as expected using these nodes so they do work. I save all and quit UE5, then reload the project and the nodes have been deleted.


I am currently having the very same issue here, I have a IA_Ship EIA event and that alongside any other ones I use disappear completely from the event graphs in my blueprints when I restart my editor.

I’m experiencing the same issue. The project was running smoothly until we upgraded from version 5.2 to 5.3. I’ve attempted various solutions to address this problem. For instance, I wrote a script to reload all the blueprints in the project. After executing this script, the game functions correctly. But, as you’ve mentioned, if I restart the editor, all the nodes disappear again. I also tried resaving all the files in the project after reloading all assets, but this didn’t resolve the issue either.

The problem seems related to the references or something similar. I might be mistaken, but when I reload a blueprint exhibiting this issue and then duplicate it, saving and restarting the editor retains the node in the duplicated version. However, when I then use the “replace references” feature to switch from the old asset to the new one and then restart the editor, the node disappears from the duplicated version!

I’m really interested in finding a solution to this problem. It seems like it affects the Enhanced Input nodes only of what I have seen. As a workaround, we might need to handle all input binding in C++. However, it feels a bit unstable. I’m not sure if it’s only the Enhanced Input nodes that are affected. Could the blueprints be corrupted? Is there an issue with loading references? I can’t tell if the problem is just with the Enhanced Input system or not.

Here are more people having this issue:

1 Like

Ahhh alright, thanks for the reference to the other post and yeah I have noticed similar behaviour when I tried to fix this myself too. Good to know that we aren’t the only ones experiencing this. :+1:

Also experiencing this issue on 5.3 :smiling_face_with_tear:

The fix is really quick.

  • Locate the Enhanced Input Plugin folder in your “EpicGames\UE_5.3\Engine\Plugins\EnhancedInput” directory.
  • Open the “EnhancedInput.uplugin” file
  • In the the Modules section set every LoadingPhase to be PreDefault

Your Modules should look like this:

"Modules": [
			"Name": "EnhancedInput",
			"Type": "Runtime",
			"LoadingPhase": "PreDefault"
			"Name": "InputBlueprintNodes",
			"Type": "UncookedOnly",
			"LoadingPhase": "PreDefault"
			"Name": "InputEditor",
			"Type": "Editor",
			"LoadingPhase": "PreDefault"

Your Modules should look like this:

Thanks! This is really useful information, but unfortunately I’m working with others… so I’ll link them to this post but this is a work around.

This works fine for me, but I’ll need to communicate this with other contributors. We don’t commit changes to Engine/, so this works great but only if the dev has made this change locally.

Thank you so much! This seems to resolve the issue.

Awesome, this has solved it locally for me, a good temporary solution! I’ve let my other contributors know about this too. :grin:

OMG, this was happening to me and was driving me insane. I am new to UE so I was wondering what was going on.

Glad it helped!

Thank you, Xperto!

I hope Epic fixes this.

1 Like

(Thanks a lot!)

1 Like

Same happening to me, do we think it’ll be fixed on the next update?

Didn’t realize this thread was a month old. There’s been an update that addresses this :slight_smile:

My savior fr fr

1 Like

Thank you! I was having the same issue and I didn’t even realize it was caused by the 5.3 update

1 Like