Engrams Reset Death and Ignored by Carnos

I started a new map and got killed by a level 56 saber almost immediatly (used same character, just reset map so I still had all my engrams and dinos obviously recognized me), but after respawn I noticed I could just waltz right by scorpions and rexes. Also I had to reselect all my engrams. The engrams also reset every time I exit and come back into the game. Wondering if anybody else has experienced this. I do have my playerpawntest (custom) duplicated and parented to what the original is parented to. For some reason I feel like this may be the problem but I really didn’t want to have to start over again. I know it comes with modding, but would that cause all those problems upon respawn?

So I suppose no one has come across this. Problem with making the playerpawntest (custom) a child is that you can no longer edit the primalinventory in the components. Not sure if you would have to create another primalinventory and write a script to point to it, or if you’re just not supposed to make it a child.

How are you replacing the primalinventory? As a component? or just the bp?

Couldn’t locate the inventory component bp that is attached to the playerpawntest. I had to edit the one in components. Do you know where the bp is located? Does it have a different name? I couldn’t find a reference to it from the playerpawntest.


Custom Crafting Benches - ARK: Survival Evolved - Unreal Engine Forums (this shows you exactly where to find the inventory component in the last picture posted)

once you do it this way, you shouldn’t need a custom playerpawn, which should clear up this issue.

I will see if I can find something after work, but a couple of things off the top of my head. When I make a custom playerpawn I can go to components and edit the values just fine. If I make the playerpawn a child of the original I am no longer able to edit, delete, or rename it under components and I can’t seem to find a reference to the inventory in the reference viewer.

Okay, so I’ve semi figured this out. with playerpawntest(custom) parented to the original, I went into components and added a new primalinventory1_0 (original is primalinventory1). After changing the values in the added one, the changes took effect in PIE. I was figuring it would try to find the original name first, but obviously it sees if you’ve made any new entries to override the original. So, second part of testing, reset my map and see if the changes take place. If not, try resetting the character and the map (hopefully not necessary).

I believe this solved the problem with only resetting the map. So if you want to change your starting blueprints in your inventory, go into the playerpawntest(custom) (parented to playerpawntest) components and add a new component (copy of primalinventory1) and edit the new one and it will work. :slight_smile: Happy days!

Good job on figuring the rest of this all out. I came back to check in on the status, and it’s all handled from the looks of it. +1 for you good sir, and thank you for documenting it all as well. Hopefully it will help some others out in the future here :slight_smile:

Awesome info here guys! I’ve been toying with this as a way to give a freshly spawned character every engram, but it never seems to override the original primalinventory1. I tried parenting the PlayerPawnTest and copying the primalinventory1 to input my new values, but it doesn’t seem to use them. I was thinking it may have to do with PlayerPawnMale/Female being parented by the original PlayerPawnTest, but remapping all of that would be crazy. Any idea if remapping NPC would work for PlayerPawn remapping?

I may be reading that incorrectly, but your custom playerpawnmale and female should have your custom playerpawntest as the parent. Remapping npcs shouldn’t be necessary. To reparent, when you are editing something go to file in the editor window and choose reparent from the drop down list and type in the name of the original and select the original. When you create the new primal inventory in components, did you go to add component and direct it to primalinventory1? Once it adds it, it should be called primalinventory1_0 or something similar. I didn’t copy and paste the original, so I don’t know if that might have something to do with it. I’m currently waiting for the total conversion update before I start messing with it again.

Yeah, I was copy/pasting it. I’ll try adding to see if it works, thanks!