Engine working very slow when foliage is laid; even when the settings are dimmed down

Basically that. Foliage makes the whole pc lag very much. Maybe I’m doing it wrong?

Hi Denathorn,

Using lower settings alone will not save on performance necessarily, even if you have a lot of objects in your scene. If you’re using the foliage tool with anything you’ll want to make sure that you’re doing the following to keep performance up.

  • Use multiple LODs for your static meshes
  • turn off cast shadows for meshes like Grass. (fewer shadow casting meshes can help performance greatly!)
  • use Cull Distances with either a Cull Distance Volume or in the instance settings for min and max values.

We have pretty high-end machines here that we work off of and not using the things above will kill performance.

I hope this helps.


For me personally, and I’m on a macbook pro, I turn off nanite on static meshes that are being used as foliage. After letting the new textures render for a while, it then becomes smooth and the frame rates pick back up.