Engine Crashes with video drivers crash and reset

Recently I have started having a problem with the engine crashing and getting an video driver crash and reset. I am running 4.8.2 of UE4.

My system:

AMD-FX 8320

Radeon R9 285 2-GB

8 GB RAM

Windows 7 Pro

I’ve tried both the Catalyst 15.4Beta and Catalyst 15.7 video drivers and it happens with both.


I have not found exactly what action is going the problem. I have had it happen while working on a blueprint, on a material, and building a map.

In the log I find this:

[2015.07.24-00.54.03:301][147]LogD3D11RHI: InitD3DDevice
[2015.07.24-00.54.13:124][145]LogMaterial:Warning: Material /Game/SuperGrid/Materials/Base/M_SuperGrid_SingleColor.M_SuperGrid_SingleColor needed to have new flag set bUsedWithSplineMeshes !
[2015.07.24-00.54.13:133][145]LogMaterial: Missing cached shader map for material M_SuperGrid_SingleColor, compiling.
[2015.07.24-00.54.13:201][145]LogMaterial: 0.000146 seconds spent updating 1 materials, 1 interfaces, 1 instances, 0 with static permutations.
[2015.07.24-00.54.52:797][137]LogEditorViewport: Clicking on Actor (LMB): StaticMeshActor (SuperGrid_Plane)
[2015.07.24-00.54.55:497][431]LogEditorViewport: Clicking on Actor (LMB): BP_Wall_C (BP_Wall)
[2015.07.24-00.55.29:486][400]LogD3D11RHI:Error: Direct3DDeviceIMContext->Map(TempTexture2D,0,D3D11_MAP_READ,0,&LockedRect) failed
at D:\BuildFarm\buildmachine_++depot+UE4-Releases+4.8\Engine\Source\Runtime\Windows\D3D11RHI\Private\D3D11RenderTarget.cpp:603
with error DXGI_ERROR_DEVICE_REMOVED
[2015.07.24-00.55.35:846][400]LogWindows: FPlatformMisc::RequestExit(1)
[2015.07.24-00.55.35:846][400]Log file closed, 07/23/15 19:55:35

Also attached is the DxDiag info

DxDiag.txtt

I don’t not get a UE4 Crash report window either.

Any sort of help would be much appreciated, I am at a loss.

Hello SoilworkerX -

Thank you for your report. We will look into this issue shortly. In the meantime, since the crash reporter is not popping up can you review and answer the following questions? It will help us speed up trying to assist you in discovering the root cause of the crash.

  • Does this happen in all projects, including a Blank Project with no Starter Content?
  • Can you be as specific as possible about what you are doing in the editor immediately before the crash? If this is not happening in a Blank Project, please also include details about the project that you are using?
  • If you can please look in Windows Event Viewer, and find the Critical or Error Logs which correspond to the time of your crash and post them here as well.

Thank You -

Eric Ketchum

Thanks for the response Eric.

  • I honestly haven’t tried a different project, I will try that this afternoon.
  • It seems like most of the time it happens while working on in the blueprint editor but I have had it happen in the main editor and the material editor. The most recent time it happened(which was yesterday), I was working in the main editor. I have a blueprint that I created based off of the spline roads tutorial. I was manipulating the spline points in the editor when the crash occurred. Screen goes black for a few seconds then comes back and I get the messages about the video driver crashing and recovering. The UE4 editor is crashed and gone by this time and the launcher is unresponsive and I have to end the process in the task manager. All other applications work after a few seconds. As far as the blueprint that I was using, I could post the blueprint itself this afternoon if that would be helpful. The project I am working on is a basic FPS project that I have started. I’m not really that far in actually, I don’t have a lot of assets in the project yet. Really just a few UI Widgets, and few blueprints, the beginnings of character and animation blueprints, and two barely started levels.
  • I can get the exact log from the event viewer this afternoon, but I know it said something like “Display driver amdkmdap stopped responding and has successfully recovered.”

Additionally, I have not experienced any issues running anything else on my system. I have run GTA V, World of Warships, and COD 4 without having any graphics or driver issues.

I’ll get the additional things posted this afternoon as soon as I can but I wanted to get as much information to you as quickly as I could. The engine and the support has be awesome even for a hobbyist like myself. Thanks for the effort and if more info would be helpful I will gladly provide what I can.

I have run some tests and got some interesting results.

I ran the Generic Shooter Sample Project that I purchased and downloaded from the marketplace. I was running the game in the editor window when the same problem occurred. Video drivers crashed and reset.

I then ran the Content Examples project. I tried loading the Blueprints Advanced map and the editor crashed. I did not get a video driver crash this time. Here is the crash report

CrashReport

I checked the windows event view and found this message which appears to occur whenever the video drivers crash.

Log Name:      System
Source:        Display
Date:          7/24/2015 4:36:31 PM
Event ID:      4101
Task Category: None
Level:         Warning
Keywords:      Classic
User:          N/A
Computer:      
Description:
Display driver amdkmdap stopped responding and has successfully recovered.
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Display" />
    <EventID Qualifiers="0">4101</EventID>
    <Level>3</Level>
    <Task>0</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2015-07-24T21:36:31.000000000Z" />
    <EventRecordID>41897</EventRecordID>
    <Channel>System</Channel>
    <Computer></Computer>
    <Security />
  </System>
  <EventData>
    <Data>amdkmdap</Data>
    <Data>
    </Data>
  </EventData>
</Event>

I have not had a crash on a blank project yet. I ran a blank project and tinkered around a bit but didn’t suffer any crashes.

Hey SoilWorkerX,

Thank you for taking the time to write the detailed report. Fortunately this is a known and reported issue UE-17205, and has been marked fixed for an upcoming engine release. We appreciate your patience while we worked to find a solution, and ask that if you have any further questions or comments simply reply to this post in a comment.

Thanks,

Andrew Hurley

Thank you for the response Andrew. Good to know you guys are working on it.

Any updates or time frame for this issue? Everything crashes making the engine completely unusable for me.

He SoilWorkerX,

This was reported as fixed internally and should not longer still occur. Can you verify this is still occurring in the most recent 4.9.1 binary release?

Would you also mind providing me with your crashlogs generated from the crash so I can compare them to the original callstacks?

Thank you,

Andrew Hurley

So I downloaded the Infiltrator demo and tried to run that.

My specs have changed slightly:
All the same except now 16GB RAM and Windows 10 Pro

Here is the log from the demo when it crashes. I do not get an Unreal crash log like a lot of other problems cause.

Log File

I did a little looking around and saw online that the common cause of the DX error DXGI_ERROR_DEVICE_REMOVED is from overclocked or overheating video cards. Mind you that this is what I read in several places, I have not conducted that research myself and can not verify that result. My card isn’t overclocked and I watched the temperature of the GPU during the demo. It didn’t get any higher the 53 C. I tested to see what the GPU ran at under a different game, for GTA V it got up to 58 C but I never had any problems or crashes. I have no other problems with any games or software. This is unfortunately the only piece of software that is causing any problems. Even the Unity and CryEngine editors work without a problem.

Even a brand new project using the FPS template crashes with the same error.

Please let me know if I can provide any additional info.

I appreciate the assistance. I really like UE4 and would like to continue using it.

Thanks,

John

Hey SoilworkerX,

So the logs you provided do not give me enough information to go off of, in order to determine the issue you are experiencing is related to your original post. If you can reproduce the crash on your end, and a Crash Report window appears, please provide me with the callstack from that crash.

Would you mind taking a look at our How to Report a Bug sticky post on the Forums?

It will provide you with all the correct instructions on how to make an official bug report on the AnswerHub including all the information we will need in order to move forward with the reporting/troubleshooting process.

On another note, I noticed in your original dxdiag you are using an AMD card, which have reported known issues causing the editor to crash. We are attempting to gather as much information on this issue as possible, in order to determine the root cause of the issue.

Thank you,

Andrew Hurley

I have an R9 380 and have had crashing in the Infiltrator Demo. I should note that I haven’t had any problems running the editor or in a Kite Demo that I migrated to 4.9.

After the video driver dies and restores itself, the client produces a popup window stating something to the effect of “the video driver has stopped responding, UE4 will now close.” So technically speaking, UE4 is not really “crashing” so we don’t get to leave a crash report.

However that doesn’t mean UE4 is without fault, it could very well be abusing the video driver, causing it to lock up, because UE4 is one of the few places where it does, and those of us with this card have had little to no trouble anywhere else.

Also, I found that if I run the Infiltrator Demo with the -DX12 argument I am able to run the demo (looped at least twice) without a hitch.

Supposedly this was all fixed in 4.9.1, I’m in the process of re-installing 4.9.1 because I installed over 4.9.0 when installing it the first time. I’ll keep this post updated.

If he’s getting the same error as the rest of us, UE4 is not “crashing” so we don’t get to leave a crash report. The client produces a popup window stating something to the effect of “the video driver has stopped responding, UE4 will now close.”

However that doesn’t mean UE4 is without fault, it could very well be abusing the video driver, causing it to lock up, because UE4 is one of the few places where it does, and those of us with this card have had little to no trouble anywhere else.

Or maybe UE4 isn’t “abusing” the driver, but using some unique feature that isn’t properly implemented on the AMD side, in which case figuring out what that is would help Epic present the bug to AMD’s driver team.

UPDATE #1: I just ran the ElementalDemo and went AFK for about 45 minutes, when I got back it was still running. Next I’ll try Infiltrator.

UPDATE #2: Well, about 10 seconds in the Infiltrator demo crashed. Here is the log…

I noticed the log said it was running a Win32 version of the demo. I’m going to attempt a 64 bit build of the game dll. Update on result incoming…

Same thing.

I should note that I can run the whole thing in PIE, multitask (using Chrome), etc etc, no problems at all.

From that log what appears to be happening is first timeouts are being recorded by the render logger. Eventually our d3d device gets removed perhaps as a consequence of the many timeouts, which in turn causes the driver to crash.

Hey Bleakwise,

Would you provide me with your systems hardware specifications so I can add this information to the report?

As I mentioned, we are aware of the issue with the AMD and will continue to investigate the issues caused by these components. Thank you for providing me with updates of your troubleshooting process.

Have you made sure to update your GPU drivers?

Thank you,

Andrew Hurley

Hey, I today installed my new GPU (R9 390) and I now also get this problem in some projects… It’s often happening while I have a minimized standalone game running and then watch youtube videos in chrome. It has not happened while I only used the editor or while I played the standalone version of the kite demo. I get the same DXGI_ERROR_DEVICE_REMOVED like the others printed in the log.

Andrew, could you explain what exactly the bug UE-17205 is set for? Just regular problems with AMD GPUs? That’s a bit generic I think. Is it only affecting certain configurations, certain GPUs, certain OSs, could you give some info on that?

I’m using 4.9.1 and Windows 7 64bit and my GPU drivers are up to date, I’ve tried both the latest stable driver and the latest beta driver. I did not have these issue with my old GPU (Radeon HD 7850).

Hey all,

So I have gone ahead and entered a bug for the specific issue dealing with the AMD R9 380 & 390 Series Cards/Drivers crashing or timing out. The bug entered is UE-21389, and highlights the issues you have mentioned as well as some other important things to note about this issue.

The original bug I linked was marked as fixed, and was determined as unrelated to the issue you are experiencing. As I mentioned earlier however, we are attempting to get these cards in some of our own machines so we can test compatibility against these drivers and get a fix implemented sooner.

There are enough users experiencing this issue to have a good amount of community interest added to the bug in order to have its priority bumped up a little bit. If you have have any other questions or need further assistance please let me know. As a point of reference, below are links to other users experiencing the same issue who might have a temporary workaround until we can get a fix implemented.

AMD R9 Very Frequent Crashes

Why is my AMD Driver Crashing?

Unreal Engine has Stopped Working on Startup

Thank you for your patience while we gathered the necessary information to have this bug report entered.

Cheers,

Andrew Hurley