Ending game causes network connection issue

Please select what you are reporting on:

Unreal Editor for Fortnite

What Type of Bug are you experiencing?

Network connection issues when trying to do anything from uefn session related.


Pushing verse changes causes network connection lost.

Steps to Reproduce

Open project
Launch session
End game or push changes

Expected Result

Lobby restarts and youre in a new game with the new changes

Observed Result

Network connection lost. Session connected even though its not
Also this error

Network error occurred when connecting to a server after matchmaking completed. Error: UNetConnection::Tick: Connection TIMED OUT. Closing connection.. Elapsed: 20.00, Real: 20.00, Good: 20.00, DriverTime: 20.11, Threshold: 20.00, [UNetConnection] RemoteAddr:, Name: IpConnection_9, Driver: Name:IpNetDriver_9 Def:BeaconNetDriver IpNetDriver_9, IsServer: NO, PC: NULL, Owner: NULL, UniqueId: MCP:95893f6adb4740c0b7181c1adaa00519

Your backend is: Fortnite
Your Build is: ++Fortnite+Release-30.10-CL-34261954
Region: NAC


Windows 11

Hi @Aimjel ,
Looks like you are on Windows 11. If your project located on OneDrive then there is a problem which Epic is looking into. A few bug reports have been added.

Basically only certified Microsoft applications can write to OneDrive and by default Windows 11 uses OneDrive. When you open UEFN you will see all Projects are created in OneDrive.
VS Code, hence Verse, cannot write to OneDrive in due to Windows 11 enhanced Security.

I just checked and my project is not apart of the OneDrive folder.

If i start a game using UEFN and end the game in fortnite then the network connection is also lost. Im so confused I need solutions!

hi @Aimjel ,
There is definitelty a occasional/transient network problem. Tried “ping” from Windows Command prompt and at 0503 GMT London, UK it worked 122ms ping thats 23:00 PST NA.
Now 10:42 GMT I get ping request error time out on both my machine Win10 and Win11 in London.

This is not a Windows 11 fault

Trace route commands fail.
Ip locator say address in Texas

Hey i tried again this morning and same problem.

Here is my output log of the day lol.

LogOnline: Error: EOS: UEOSSettings::GetSelectedArtifactSettings() ArtifactName=[Fortnite] no settings found.
LogOnline: Error: EOS: FOnlineSubsystemEOS::PlatformCreate() GetSelectedArtifactSettings failed
LogGameFeatures: Error: Game feature 'JonseyCosmetic' transition failed. Ending state: ErrorRegistering [ErrorRegistering, ErrorRegistering]. Result: ErrorCode=GameFeaturePlugin.StateMachine.Registering.Plugin_Missing_GameFeatureData
LogCoopNotesSidePanel: Error: Invalid browser Widget when load completed
LogNet: Error: UEngine::BroadcastNetworkFailure: FailureType = ConnectionTimeout, ErrorString = UNetConnection::Tick: Connection TIMED OUT. Closing connection.. Elapsed: 30.01, Real: 30.01, Good: 30.01, DriverTime: 139.30, Threshold: 30.00, [UNetConnection] RemoteAddr:, Name: IpConnection_0, Driver: Name:IpNetDriver_0 Def:BeaconNetDriver IpNetDriver_0, IsServer: NO, PC: NULL, Owner: ValkyrieBeaconClient_0, UniqueId: MCP:95893f6adb4740c0b7181c1adaa00519, Driver = Name:IpNetDriver_0 Def:BeaconNetDriver IpNetDriver_0
LogValkyrieRequestManagerEditor: Error: Failed to handle connection attempt (Network error occurred when connecting to a server after matchmaking completed. Error: UNetConnection::Tick: Connection TIMED OUT. Closing connection.. Elapsed: 30.01,

ping is over 130 ms
read this article anything above 50 millisecond is bad
How To See Ping On Fortnite (gamerant.com)
Just tried and my ping is 4 to 21 milliseconds
The thing is I have check connections and many are in Amazon AWS datacentres in the US transferred from Amazon Europe EMEA

I solved the problem. Some how my verse device was causing the problem. I commented all the code and nothing happened but when I removed the verse device from the level everything worked again as expected.

1 Like

hi @Aimjel ,
Do you know which verse device caused the problem, so can test on London servers and see where this connects

Maybe check you’ve referenced all the needed verse modules up top of your verse code like using { /Fortnite.com/Characters } (does this one do the JonseyCosmetic ?) ???