Download

Enabling lights in one room darkens another room

Okay so I have a very weird problem

At present this is what my hallway looks like with no spotlights enabled in the level.

817c465b7d32a25f68c63501969d6841731cca55.jpeg

When I enable spotlights in a room on the other end of the residence (completely separate and mostly enclosed), the hallway gets darker.

133b13153b70160edb9cfde73c78910a5ae5eee2.jpeg

If I increase the intensity of those spotlights (from 30 to 100), it gets even more dark:

If I turn all the spotlights in my various rooms on, the hallway gets way way more darker and introduces artefacts and blotchiness.

deb3bd33a8a93cb1109f93efd883f017250e7ee8.jpeg

At first I thought somehow the lights in my rooms were interacting with the hallway but that’s not the case. I added two random spotlights at the edge of my map, pointed them out into empty space away from the model and…

Hallway gets darker still.

Is this some kind of bug? It’s been such a frustrating problem. All spotlights are static and simulate downlights so cast shadows are on and inverse square falloff is enabled.

Random thought, maybe it’s because of Automatic Exposure set in your camera/post process volume ? Try to deactivate it and check if you still get this effect :slight_smile:

Nope that didn’t work! It’s more or less the same since it’s all baked into the surfaces. It was a nice thought though :smiley:

Okay so after an absurd amount of testing, the reason for this is because I was building at medium quality. I didn’t build at production because it takes about an hour per build which is a little too long when just trying to test lights in your level. And the reason I didn’t use preview can be seen in my old post here: https://forums.unrealengine.com/showthread.php?40787-Same-material-different-appearance-light-bleeding&p=150327&viewfull=1#post150327

Medium quality with all my spotlights in the level turned on:

d76e10ac751e132777082080b339388fb5801e2a.jpeg

Production quality with all of them turned on:

e70cf78d4ca1d7a9d1015ac25affbfddeee79083.jpeg

So in conclusion, never ever build below production. Not even for testing, because they’ll end up being completely irrelevant/inaccurate. Also this raises more questions than it really answers but oh well.

I’m wondering if there’s some sort of cap on what lightmass calculates for non-production lighting; e.g. the more active lights, the fewer passes it’s taking for each light in the scene, so the less ambient light you’re getting.

That sort of makes sense, and it seems to be the only good explanation I can think of. It’s a shame that preview and medium quality are not accurate enough though. You’d expect a little bit of bleeds and shadow blotches at lower levels but not completely pitch black rooms!

Update:

Doesn’t seem to be related to production quality anymore. I added a couple lights and fiddled around with a few settings and it came back. So something funny is still going on

Are you using Stationary or Static Lights? Stationary lights that overlap each other can generate lighting errors I believe, though I can’t remember if that affects stationary light.

A few other things to check:

  • Have a Lightmass Importance Volume (I imagine you do anyway).
  • Bump up the number of samples (will increase build times dramatically).
  • Check post-Process isn’t nuking anything out, such as Indirect Lighting Intensity etc.
  • Make sure AO isn’t being baked into lighting. That can have a pretty dramatic effect sometimes (it’s off by default).

Thanks for the response TheJamsh

All the spotlights in my level are static, the only lights that are stationary are my directional light and skylight. All lights have cast shadows enabled.

-Lightmass importance is in there already
-Bumping up the number of samples = static lighting level scale? I’m not sure what you mean here
-Definitely not my post process, it’s the same whether it’s enabled or disabled
-This is the AO in the world settings right? It’s already switched off

Interestingly enough ** I can replicate this effect in the realistic rendering demo **(production build and default settings).

output_nFQYEt.gif

  • 1 random spotlight outside (mildly brighter, actually looks better than default)

  • 2 random spotlights outside (darkens)

+4 random spotlights (brightens)

+7 random spotlights (darkens the most)

Location of test spotlights

In that test the room changes seemingly at random, even though the test spotlights shouldn’t have any affect on the room whatsover.

In my project there are just over 40 static spotlights. Adding one spotlight darkens the hallway, causes massive colour bleeding in the scullery and puts shadow artefacts into a third room. Adding another light fixes the problem in two of the rooms while the 3rd suffers even more. Adding another light on top of that changes all their appearances yet again. As far as I can tell, there’s no real pattern here. Just like with the realistic rendering demo tests

I don’t believe it’s my system either. I did the realistic rendering tests on a laptop (Windows 8.1, Nvidia GTX 860M), while the main project is here on my desktop pc (Windows 7, Nvidia GTX 980).

You can try the experiment and see for yourself

Maybe an unreal engine tech can come in and explain whats going on? :frowning:

Update:

So as another test, I ‘upgraded’ my baselightmass.ini file and replaced the production level parameters with those used by Koola.

[DevOptions.StaticLightingProductionQuality]
NumShadowRaysScale=32 (up from 8)
NumPenumbraShadowRaysScale=64 (up from 32)
ApproximateHighResTexelsPerMaxTransitionDistanceScale=9 (6)
MinDistanceFieldUpsampleFactor=7 (5)
NumHemisphereSamplesScale=64 (8)
NumImportanceSearchPhotonsScale=6 (4)
NumDirectPhotonsScale=32 (8)
DirectPhotonSearchDistanceScale=.5
NumIndirectPhotonPathsScale=32 (2)
NumIndirectPhotonsScale=64 (8)
NumIndirectIrradiancePhotonsScale=32 (2)
RecordRadiusScaleScale=.45 (.5625)
InterpolationMaxAngleScale=.75
IrradianceCacheSmoothFactor=.75
NumAdaptiveRefinementLevels=3
AdaptiveBrightnessThresholdScale=.25
AdaptiveFirstBouncePhotonConeAngleScale=2.5

Result:

Fixed everything. Next to no bleeds, shadow artefacts or anything which leads me to believe that it’s one of those settings. I don’t have the patience to find out which setting or combo of settings it is though. Also downside to this though is a 6 hour build (and I haven’t even put furniture in yet).

hey dude!

great to read through this; I noticed some blotches in my builds too, but wasn’t really at a point where it seemed necessary to investigate further. now I got the answer right here :smiley:
just out of curiosity, though:
it takes you 1 hour(!) to build the scene which is like a hallway and 4 rooms ?! or 6 hours now with the new settings?? :open_mouth:
I got like a whole flat floor loaded in the engine (with bits of furniture) and it takes like 5 minutes on production quality.
I’m just asking, because I wanna be prepared for potential bottlenecks further down the line.

cheers!
chris

Just thinking aloud here, I wonder if this is because when you place a new light, the engine re-assesses where the probes for lightmass should be and as such, some areas suffer because of the new spreading-out of things. I’m not sure if that even happens but it’s the most logical conclusion I can come too.

That .ini file from Koola increases the amount of sample by quite a bit to compensate I guess… But then his work speaks for itself.

My project is a massive condo/residence type thing. In real life the actual building spans about 100m /330 ft in length and has about 30 rooms/explorable areas. The hallway images was just the worst affected area. But yes at default production quality it takes about 55mins. With the updated baselightmass.ini it takes 6 hours ish.

If you only have minor blotches try mess around with the World Settings first. Ram the indirect lighting bounces to 100 and bump the indirect lighting quality up to maybe 2 and see what happens first. Medium/Production quality worked really well for me in the beginning until I started adding artificial spotlights in my bathrooms…

That’s what I’m thinking too. It felt like lightmass was ‘running out of juice’ so to speak. I wonder if someone from Unreal can come and comment

Funnily enough I was itching to use his baselightmass.ini settings some couple months ago but I forced myself to stay away (because of build times). I was frustrated and all out of ideas until I tried his so I’m glad I did haha.