Download

Enable VR stereoscopic mode and hmd commands without Rift? (not -emulatestereo)

Hello, I’m without my DK2 at the moment, but I’d like to test in VR mode for some performance analysis.

The -emulatestereo argument just enable a stereo split screen mode, but there’s no chromatic aberration and no hmd commands, like, for example, “hmd sp 100”.

Is there a way to enable those commands and effects? Thanks.

In level blueprint add execute console command: stereo on

Thanks, but that doesn’t work.
Without a Rift connected, this and others hmd specifics commands don’t work, you just get a “Command nos recognized: stereo on”, and they don’t even show in the autocomplete when you start typing.

Any other suggestion?

Did you check to see if your Rift plugin is enabled? If it isn’t, enable it, restart your editor, and save your project with it enabled. It may have been disabled if you don’t currently have one plugged in. If you have never had one at all, you may have to download the runtime and have it running in the background. Then set the Rift Display mode to extended. Also note that you can’t go into stereo mode inside the editor. You will either have to launch the game from within the editor or right click on the project file and click ‘Launch Game’. The last thing to mention is that you may also have to fullscreen for stereo to turn on.

It is not currently possible since Oculus plugin gets stereo rendering parameters from the Rift.