Download

Emissive Materials Jitter with Motion Blur

I love the UE4 motion blur, but in my latest project I am using emissive mats to have a Tron like neon glow. With motion blur on, whenever you turn fast enough, any emissive materials affected by the blur will blare and change its look to a harsh glow. Is there a way to fix this?

I don’t know exactly what you mean but I’d start with a post-process volume and mess with the bloom and motion blue settings. Can you post a screen grab of what you’re talking about?

Recorded a video to demonstrate what I’m talking about. Surprised this isn’t a common issue for everyone. That or people don’t use emissive materials all that much.

https://youtube.com/watch?v=xLdfD0lX_74

hmm yeah that looks like a bug. I found this https://answers.unrealengine.com/questions/169958/flickering-emissive-glow.html and if that doesn’t fix it (scroll down for the answer)
post your bug here https://answers.unrealengine.com/spaces/11/bugs-and-crashes.html

I have seen that on a monster I have with an emissive eye. It’s identical to your video. I have bloom subdued somewhat and the eye’s glow is not very noticeable otherwise.

Hey sbnewsom,

Can you provide some relevant information for your setup. Using basic settings and emissive materials does not yield the same results for me.

It would be helpful to know the following:

  • Changed Post Process Setting (select PP > Click Eye in top right > Select Show Modified Only)
  • Lighting mobility (movable, static, stationary)
  • Emissive Static Meshes - are you using the flag Use Emissive for Static to bake static lighting into the scene?
  • Material setup for your emissive material. Are you just plugging the base color into emissive or are you using a multiply to increase the emissive power?
  • is this happening in just this scene or if you place the mesh in a blank level with the same post process settings do you get the same results?

Thank you!

Tim