Emissive Material Not Lighting Surface

I have an emissive material set up which seems to be working fine except it does not light up the surface below it as one would expect. I have tried several things such as turning up intensity and bloom but nothing seems to really change. I am attaching a screen shot of the light and the material setup. Thank you for any suggested.

In the material parameters you need to enable Use Emissive for Static Lighting

Just note that emissive materials don’t work that well for lighting.

Thank you for the response Darth. I know the material does not work that great for lighting (it doesn’t in Vray either) but I cannot think of a better material for the simulation of Christmas lights. I am open to suggestions though.

As far as your suggestion “In the material parameters you need to enable Use Emissive for Static Lighting”, are you sure you do not mean in the static mesh parameters? I am not seeing anything in the material parameters under the Details Tab

I am thinking there is not much more I can do about this… I believe it comes down to the fact that the little christmas light fixtures are so tiny and as such, they do not have the surface area to really throw off the “blow” to reflect blue onto the ground surface. Does this make sense? The reason I mention it is because if I through a decent sized cube mesh in there with the material, there is much more of the blue light being cast onto the surface area. Still, you think there would be some light color bouncing off of the surface…

Provided the emissive surface is bright enough and the surrounding illuminance is dark enough, there should be a noticeable contribution. Do you have auto-exposure enabled? It’s possible the trees are being exposed for, making any variation in light elsewhere harder to see.

Also make sure the ground mesh has a decent lightmap resolution and you’re baking with a <1 world scale in the Lightmass settings.

Emissive goes with skylight bounces: do you have higher bounce than 1?
Also portals help tremendously! …place them covering your emissive surface!

…also I’m not sure why don’t you just imitate it with lights… + glow in postprocess

Rosegoldslugs, Thanks for the response. I have the illumination and bloom on this dialed pretty high. I think my illumination factor is 100 which I thought was kind of ridiculous but it works. I am going to check into the lightmap rez on the landscape as you suggested. Also, as I mentioned in my other post, I had turned off autoexposure in the main project settings under Default Settings which pretty much took all of that out. I think some of Makigirl’s suggestions as work arounds could solve this. My issue is I want to know why this does not work straight up. I did not expect to light the scene or anything with the emissive material but I did want that glow effect on the ground. Again, thank you for the suggestions.

Hello Makigirl, your work arounds are a good idea. I guess I was hoping the emissive could pull off the glow on its own keeping it simple. Especially since I have flashing lights on some of the objects. I have not used portals in UE4 yet so I can look into that. Adding additional lights means I need to be sure they are addressed with the timing of of the emissive material. We were going to need to add blueprints anyway so maybe we do it there. I did adjust the skylight bounces in the world settings (I think) but it seemed to not make a difference at all which was odd. I think the max I could go was 8 bounces or something like that which seemed high but I tried it anyway.

Could you elaborate on your second comment? When you say post process, you mean within UE4 or outside of it in another application like I would do with still images? Sorry, I am still working on getting up to speed on UE4.

It can work with emissive only /see attachments/!! Why it doesn’t work straight up? :smiley: …I’m sure it’s not new to you that you have to set things in softwares to get the result you want! :wink: So if you set your scene properly it will work! :wink:
One more time:
…as I’ve said emissive goes with skylight bounces: do you have a higher setting than the default 1?
Do you have portals covering the emissive surface?

I meant in Unreal:

Skylight bounces are under world/lightmass settings: you can go up to 100 /I’d stay under 20/…

[QUOTE="Makigirl;n1642503"Why it doesn’t work straight up? :smiley: …I’m sure it’s not new to you that you have to set things in softwares to get the result you want! :wink: So if you set your scene properly it will work! :wink:

Yup, and that is what I was worried about and thought for sure was the case. USER ERROR! haha. I am still trying to figure out UE4 so I will be the first to admit I do not know all of the settings an the impact they have on everything. IT took me awhile to learn Vray for 3dsmax and the same seems to be occurring with UE4. I am just appreciative there are some people like you around to help push me in the right direction.

I don’t know about portals in UE4 so I will need to check them out.

No worries! We all had to learn from zero! :wink:
Portals basically are “sample magnets/boosters” /sorry Epic!! :D/ So if you need more concentrated samples in your scene at a certain place: place one there!! …well mostly it used in archviz in openings (windows/ doors) and for emissive to get the proper result…

Thanks again Makigirl. I will give the portals a look. Like you said, I am familiar with them through my use of archviz and with my rendering software. I just wasn’t aware of them in UE4.

I went into the world settings and changed the values not only of the skylight bounces, but also some other items in there such as indirect bounces. I crank it to 100 and there was not one difference in the scene. Everything I have ready has that light bounce setting done in a situation of building interiors or similar. It makes me wonder if in a night scene like I have that is an open outdoor environment, it is not really registering.

What is your emissive intensity/strength? …could it be too low? Set a really high intensity and see if it burns out the scene… /it should!!/

So I tried to create an attachment showing a couple of things. It is messy but you get the idea. The first attachment is from a 3dsmax rendering that shows the effect I am after. The second image is my scene and there is no glowing. Bloom is cranked in the Lightmass Volume and I even tried the Sky bounces at 100 in world settings. Emissive as lighting is selected for the light meshes. Material is cranked to 100 in intensity. I am just not sure what to do. I tried playing around with Portals but I am not quite getting them.

Ok, so right now the problem is that you don’t see the lights hitting the ground?

that has been the issue from the start. Maybe I did not correctly state or describe that but yes, most definitely is the issue.

if it helps, I can post screen shots of other settings. I think I have things set up but you just never know. Plus, there is no reflected lighting on the ground at all which I just find hard to believe that I need to accept in UE4

Sry, I thought it was also the glow around the lights… :S :wink:
Ok… so maybe it’s just the ground then! …maybe THAT doesn’t have a high enough lightmap resolution to visualize the lights!
Could you try to place a smaller mesh under any of the christmas lights? …like a stand if you understand me… and set like a 512 or 1024 lightmap res to it and build light?