Emissive material does not glow

Hello,

I was following an 4.10 UE4 lightsaber tutorial, in which the person creates a glow effect around a material.
So in 4.10 when you give a material emissive output, you get a glow around the material,

but in 4.14 you dont. Something must have changed in between these versions.
I migrated the material with glow effect from 4.10 to 4.14 and it stopped glowing.

I can’t think of any reasons why this is, so I my last option is to ask here,

thanks for any input!

It might be that bloom is turned off. Check your post process volume and play around with the bloom intensity value

1 Like

Thanks for the reply, So I’m guessing you need Post Process Volume and bloom enabled for the material?
Ahh, then I might understand how the effect works, thanks :wink:

I usually get glow effect even without bloom.
Have you tried to increase the emmisive input?

As long as you have the proper node setup, you should be fine. Bloom is helpful, but I suggest not to over do it!
Here is a picture of what helped me ages ago when I went to do emissive materials, and I worked from there. Hopefully it’ll be beneficial to you.
b46f7ef477a7a5a9a7cdcd99e95b6886cdb36814.jpeg

Hi, I’m having an issue that is related to emissive material glow. When I put together a material as @NicolasKruzel has, the resulting material is bright white with colored glow around the edges, instead of a fully color saturated glow as shown in his image.

697507236fc7595d523a0d156c68758a7c953ad5.jpeg

I also made another attempt at a glow material following this video, and the result was similar.

93878b43b601ef8b7387d18a44e0fbf601b4ec99.jpeg

Anyone have any ideas as to how I can achieve a nice saturated glowing color?

This looks like the changes from the new tone mapper. The image above yours likely came before the change to the way emissives operate was made.

turn on bloom from p.p. and very important from the project settings

2 Likes

Since no one gave the correct (and SIMPLE) answer, I will for posterity and anyone who is learning: (I am trying to ‘Tidy Up’ around here!)
**To get the full Saturated glow (Like NEON) effect, you need to make it an ‘*UNLIT’ material *
(it is it’s own light!) **
Click the material creation graph grid-background, then in left panel, go to the Material Drop down,change ‘Shading Model’ to ‘UNLIT’ (‘default Lit’ makes the material take on light as is happening to you…) UNLIT (un-intuitively) lets it ‘glow’ fully from the internal material expression with no external light diluting (diffusing?) :slight_smile: the effect. That should work.

The emissive input works the same way whether the material is unlit or not. You’ll get a glow effect as long as you have Bloom enabled in the default Project Settings or in a Post-Process Volume. Otherwise, if you go above 1 without bloom, the color becomes desaturated and you get the white core without a colored glow.

I don’t remember which default scalability setting knocks out Post-Process effects like Bloom, but always make sure you’re on Epic at least if you can handle it. The engine will default to lowering the scalability settings if your engine hangs for a certain period of time and you ignore the pop-up asking if you want to change it. Kind of annoying, but you can disable that too.

Base color is clamped to 1.

Good call. I’m not even sure when that change went in, since I still use the emissive input separately. Maybe I’m remembering UDK… anyway, I’ve updated my post.

Hi there, I had the same problem and spent hours searching for a clear and detailed answer. I have finally found all the pieces of the puzzle.

  1. There are the settings “bloom” once in the project settings, and additionally you can create a postprocesvolume - so these are 2 different places where you can turn them on and off.

  2. When you just use the post process volume to turn on bloom, the “glow halo” still does not show in your material window, which drove me crazy. You need to turn on bloom in project settings for it to show everywhere.

  3. There is also the “Lens Flare” that can be quite annoying depending on your scenery. By default it was turned on in my settings, and I thought it was part of bloom. But you can simply deactivate that separately in the project settings as well. Just search for both “bloom” and “lens flare” in the project settings to turn them on/off for your whole project.

I hope that will save you time researching.

1 Like