Emissive Material brightness decay so fast in distence

I use **Emissive Material **for the lights on my robots, but the brightness of the lights decay so fast in distence (like the robot No.1). It should look like in pic 2 (although blurred but the lights bright).
I have tried to make EmissiveStrength bigger, but the close lights will be too bright.
How should I do?


You can change the emissive amount based on camera distance:


thank you very mach!
I change the blueprint like pic1, it seems be better.
but it still doesn’t look like the real brightness. Is it because the lights has too few pixels? besides, I used bloom effect.
Thank you again.

I change the method of Anti-aliasing, and the bloom in distance gets obvious.

Could also have to do with engine version and emisive NOT affecting lighting around it. (Or LPV settings, which are in the post process. One of them is the distance at which the LPV is colored in based on the emissive).